summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2016-04-06 14:10:10 -0400
committerZero_Chaos <zerochaos@gentoo.org>2016-04-06 14:10:27 -0400
commit694a094a77a9e2a57b9ecf8428ef7cdb93cff37a (patch)
treea49c0caeb61f905acd237bde729fc877f2850973 /sys-apps/frandom/frandom-1.1.ebuild
parentkde-plasma/kactivitymanagerd: sort blockers (diff)
downloadgentoo-694a094a77a9e2a57b9ecf8428ef7cdb93cff37a.tar.gz
gentoo-694a094a77a9e2a57b9ecf8428ef7cdb93cff37a.tar.bz2
gentoo-694a094a77a9e2a57b9ecf8428ef7cdb93cff37a.zip
sys-apps/frandom: initial commit of frandom from bug #325541, minor modifications of ebuild to bring up to date
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-apps/frandom/frandom-1.1.ebuild')
-rw-r--r--sys-apps/frandom/frandom-1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-apps/frandom/frandom-1.1.ebuild b/sys-apps/frandom/frandom-1.1.ebuild
new file mode 100644
index 000000000000..277faaf0627d
--- /dev/null
+++ b/sys-apps/frandom/frandom-1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-mod udev
+
+DESCRIPTION="Fast kernel-land pseudo-random number generator using the RC4 algorithm"
+HOMEPAGE="http://billauer.co.il/frandom.html"
+SRC_URI="mirror://sourceforge/project/frandom//${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="strip"
+
+BUILD_TARGETS="default"
+BUILD_TARGET_ARCH="${ARCH}"
+MODULE_NAMES="frandom(misc)"
+
+src_prepare() {
+ sed -i -e "s:\$(shell uname -r):${KV_FULL}:" "${S}"/Makefile || die "sed failed"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ udev_dorules "${S}"/10-${PN}.rules
+}