summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-06-20 17:55:41 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-06-20 18:03:44 +0200
commitc3d3888b4bcd8a8c37c3c99189e041def5dd3777 (patch)
treeabb691386850886438572706f07dc24b9d60fbf0 /sys-apps/fwupd-efi
parentdev-util/byacc: bump to v20210619 (diff)
downloadgentoo-c3d3888b4bcd8a8c37c3c99189e041def5dd3777.tar.gz
gentoo-c3d3888b4bcd8a8c37c3c99189e041def5dd3777.tar.bz2
gentoo-c3d3888b4bcd8a8c37c3c99189e041def5dd3777.zip
sys-apps/fwupd-efi: bump to v1.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-apps/fwupd-efi')
-rw-r--r--sys-apps/fwupd-efi/Manifest1
-rw-r--r--sys-apps/fwupd-efi/fwupd-efi-1.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/fwupd-efi/Manifest b/sys-apps/fwupd-efi/Manifest
index bd3ce666cfba..69e486bfbc62 100644
--- a/sys-apps/fwupd-efi/Manifest
+++ b/sys-apps/fwupd-efi/Manifest
@@ -1 +1,2 @@
DIST fwupd-efi-1.0.tar.gz 37465 BLAKE2B 89824d2f32d618802f56ebdb67838eed2759a86556a54a9da4f303220d99fbd2465673181d3d2806f4665061746cf7faebf633d4de8249e2c3f269fe0c22b679 SHA512 fd2fde665e90f40fb8c2235f09fc17618d8cb3f87a23ef37f7940a36c4f4b0f9ccef90745bdca1dd8827f60060e5fd95c139883ce08aedb00a249f6e809703a4
+DIST fwupd-efi-1.1.tar.gz 37079 BLAKE2B 6f9d97f969aa8c4e7f220e7914163ddff31fa841469b30e9ca73c76d49b753edcfd6e76df68b408533deb14e230240c9d15278eb8d7d490e45f10f28a0993cd6 SHA512 ee2c1039de87a3580cbe47bb5818015936ad7ef00b3bc8fff644c858387e5c5b3fe84e075e01ff9069218b04474774abee4a13261a2d1dd786e0e6d3bfe5833b
diff --git a/sys-apps/fwupd-efi/fwupd-efi-1.1.ebuild b/sys-apps/fwupd-efi/fwupd-efi-1.1.ebuild
new file mode 100644
index 000000000000..fc3aa3397b23
--- /dev/null
+++ b/sys-apps/fwupd-efi/fwupd-efi-1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit meson python-any-r1 toolchain-funcs
+
+DESCRIPTION="EFI executable for fwupd"
+HOMEPAGE="https://fwupd.org"
+
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/fwupd/fwupd-efi.git"
+else
+ SRC_URI="https://github.com/fwupd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE=""
+
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig"
+
+DEPEND="sys-boot/gnu-efi"
+
+RDEPEND="!<sys-apps/fwupd-1.6.0"
+
+src_prepare() {
+ default
+
+ python_fix_shebang "${S}/efi"
+}
+
+src_configure() {
+ local emesonargs=(
+ -Defi-cc="$(tc-getCC)"
+ -Defi-ld="$(tc-getLD)"
+ -Defi-objcopy="$(tc-getOBJCOPY)"
+ -Defi_sbat_distro_id="gentoo"
+ -Defi_sbat_distro_summary="Gentoo GNU/Linux"
+ -Defi_sbat_distro_pkgname="${PN}"
+ -Defi_sbat_distro_version="${PVR}"
+ -Defi_sbat_distro_url="https://packages.gentoo.org/packages/${CATEGORY}/${PN}"
+ )
+
+ meson_src_configure
+}