summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-04-28 18:05:13 -0400
committerMike Gilbert <floppym@gentoo.org>2017-04-28 18:05:39 -0400
commita0d632313dd68037777083e5f834d30f411ac331 (patch)
tree44ebb5259c2d586b90cf0c0f74176f7055a3d0e1 /sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild
parentapp-admin/petrovich: EAPI 6 bump. (diff)
downloadgentoo-a0d632313dd68037777083e5f834d30f411ac331.tar.gz
gentoo-a0d632313dd68037777083e5f834d30f411ac331.tar.bz2
gentoo-a0d632313dd68037777083e5f834d30f411ac331.zip
sys-apps/gentoo-systemd-integration: bump to 7
Package-Manager: Portage-2.3.5_p31, Repoman-2.3.2_p61
Diffstat (limited to 'sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild')
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild
new file mode 100644
index 000000000000..ff74e1bd54bd
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+inherit systemd
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Systemd"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-207
+ !sys-fs/eudev
+ !sys-fs/udev"
+DEPEND=">=sys-apps/systemd-207
+ virtual/pkgconfig"
+
+if [[ ${PV} == 9999 ]]; then
+ DEPEND+=" sys-devel/systemd-m4"
+fi
+
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}