summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-09-18 10:16:09 -0400
committerMike Gilbert <floppym@gentoo.org>2021-09-19 17:38:25 -0400
commit8c1e17dde18dc56831b368d66429b1b4760ec895 (patch)
tree7e9e565fd8fc59541a57f10333234bad3697e861 /sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild
parentsystemd.eclass: introduce systemd_get_systempresetdir (diff)
downloadgentoo-8c1e17dde18dc56831b368d66429b1b4760ec895.tar.gz
gentoo-8c1e17dde18dc56831b368d66429b1b4760ec895.tar.bz2
gentoo-8c1e17dde18dc56831b368d66429b1b4760ec895.zip
sys-apps/gentoo-systemd-integration: pass systemd dirs to configure
This prevents install paths from being prefixed with SYSROOT by pkg-config. Bug: https://bugs.gentoo.org/813639 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild')
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild
index d6fa26516aad..c5acec8fc6de 100644
--- a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit systemd
+
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
inherit autotools git-r3
@@ -30,3 +32,11 @@ src_prepare() {
default
[[ ${PV} != 9999 ]] || eautoreconf
}
+
+src_configure() {
+ local myconf=(
+ --with-systemdsystemgeneratordir="$(systemd_get_systemgeneratordir)"
+ --with-systemdsystempresetdir="$(systemd_get_systempresetdir)"
+ )
+ econf "${myconf[@]}"
+}