summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-04-24 10:41:50 -0400
committerMike Gilbert <floppym@gentoo.org>2022-04-24 10:42:00 -0400
commitb8ac2178a8b961f94fe552e47861b791bf707e28 (patch)
treeb694abae0894c00dba704425a097c12b188355d5 /sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild
parentsys-apps/gentoo-systemd-integration: pass udevdir to configure (diff)
downloadgentoo-b8ac2178a8b961f94fe552e47861b791bf707e28.tar.gz
gentoo-b8ac2178a8b961f94fe552e47861b791bf707e28.tar.bz2
gentoo-b8ac2178a8b961f94fe552e47861b791bf707e28.zip
sys-apps/gentoo-systemd-integration: drop 7, 8
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild')
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild
deleted file mode 100644
index c5acec8fc6de..000000000000
--- a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-8.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit systemd
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
- inherit autotools git-r3
-else
- SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
-fi
-
-inherit systemd
-
-DESCRIPTION="systemd integration files for Gentoo"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Systemd"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND=">=sys-apps/systemd-207
- !sys-fs/eudev
- !sys-fs/udev"
-DEPEND=">=sys-apps/systemd-207"
-BDEPEND="virtual/pkgconfig"
-
-src_prepare() {
- default
- [[ ${PV} != 9999 ]] || eautoreconf
-}
-
-src_configure() {
- local myconf=(
- --with-systemdsystemgeneratordir="$(systemd_get_systemgeneratordir)"
- --with-systemdsystempresetdir="$(systemd_get_systempresetdir)"
- )
- econf "${myconf[@]}"
-}