summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-09-18 10:16:09 -0400
committerMike Gilbert <floppym@gentoo.org>2021-09-19 17:38:25 -0400
commit8c1e17dde18dc56831b368d66429b1b4760ec895 (patch)
tree7e9e565fd8fc59541a57f10333234bad3697e861 /sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
parentsystemd.eclass: introduce systemd_get_systempresetdir (diff)
downloadgentoo-8c1e17dde18dc56831b368d66429b1b4760ec895.tar.gz
gentoo-8c1e17dde18dc56831b368d66429b1b4760ec895.tar.bz2
gentoo-8c1e17dde18dc56831b368d66429b1b4760ec895.zip
sys-apps/gentoo-systemd-integration: pass systemd dirs to configure
This prevents install paths from being prefixed with SYSROOT by pkg-config. Bug: https://bugs.gentoo.org/813639 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild')
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
index 7983540e7260..0d5b07883d97 100644
--- a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit systemd
+
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
inherit autotools git-r3
@@ -28,3 +30,11 @@ src_prepare() {
default
[[ ${PV} != 9999 ]] || eautoreconf
}
+
+src_configure() {
+ local myconf=(
+ --with-systemdsystemgeneratordir="$(systemd_get_systemgeneratordir)"
+ --with-systemdsystempresetdir="$(systemd_get_systempresetdir)"
+ )
+ econf "${myconf[@]}"
+}