summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-10 01:18:16 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-10 01:18:16 +0100
commitee6618e3c33ea3fce11ae1d0821a54c13d5151c4 (patch)
tree0835b550f53c934335e8c6c392ce341598b0ca9f /sys-apps/gscanbus
parentsys-apps/memtester: Port to EAPI 7 (diff)
downloadgentoo-ee6618e3c33ea3fce11ae1d0821a54c13d5151c4.tar.gz
gentoo-ee6618e3c33ea3fce11ae1d0821a54c13d5151c4.tar.bz2
gentoo-ee6618e3c33ea3fce11ae1d0821a54c13d5151c4.zip
sys-apps/gscanbus: Port to EAPI 7
Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-apps/gscanbus')
-rw-r--r--sys-apps/gscanbus/files/gscanbus-0.8-Wimplicit-function-declaration.patch22
-rw-r--r--sys-apps/gscanbus/gscanbus-0.8.ebuild14
2 files changed, 29 insertions, 7 deletions
diff --git a/sys-apps/gscanbus/files/gscanbus-0.8-Wimplicit-function-declaration.patch b/sys-apps/gscanbus/files/gscanbus-0.8-Wimplicit-function-declaration.patch
new file mode 100644
index 000000000000..79a585694ab0
--- /dev/null
+++ b/sys-apps/gscanbus/files/gscanbus-0.8-Wimplicit-function-declaration.patch
@@ -0,0 +1,22 @@
+--- a/decodeselfid.c
++++ b/decodeselfid.c
+@@ -25,6 +25,8 @@
+
+ #include "decodeselfid.h"
+
++#include <string.h>
++
+ void printbin(FILE *stream, unsigned int i, unsigned char width) {
+ int j;
+ for (j=0; j<width; j++) {
+--- a/fatal.c
++++ b/fatal.c
+@@ -18,6 +18,8 @@
+ */
+ #include "fatal.h"
+
++#include <stdlib.h>
++
+ void fatal(char *s) {
+ fprintf(stderr, "Error: %s\n", s);
+ exit(1);
diff --git a/sys-apps/gscanbus/gscanbus-0.8.ebuild b/sys-apps/gscanbus/gscanbus-0.8.ebuild
index 693ade0c091f..98a308f1c30c 100644
--- a/sys-apps/gscanbus/gscanbus-0.8.ebuild
+++ b/sys-apps/gscanbus/gscanbus-0.8.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
DESCRIPTION="Bus scanning, testing and topology visualizing tool for Linux IEEE1394 subsystem"
HOMEPAGE="https://sourceforge.net/projects/gscanbus.berlios/"
@@ -10,11 +10,11 @@ SRC_URI="mirror://sourceforge/${PN}.berlios/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
-RDEPEND="sys-libs/libraw1394
+RDEPEND="
+ sys-libs/libraw1394
x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-DOCS=( AUTHORS README TODO )
+PATCHES=( "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch )