summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-11-13 15:22:53 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-11-13 15:23:36 +0100
commitf60e0d116e9c9c1aacf5ca604cb38fb68829742b (patch)
treef377982d2228247c44436af98852b553e52b4453 /sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild
parentsys-kernel/gentoo-sources: Linux 4.14. Patch to support for namespace user.pa... (diff)
downloadgentoo-f60e0d116e9c9c1aacf5ca604cb38fb68829742b.tar.gz
gentoo-f60e0d116e9c9c1aacf5ca604cb38fb68829742b.tar.bz2
gentoo-f60e0d116e9c9c1aacf5ca604cb38fb68829742b.zip
sys-apps/gsmartcontrol: Bump to version 1.1.3
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild')
-rw-r--r--sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild b/sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild
new file mode 100644
index 000000000000..4757ae7e2385
--- /dev/null
+++ b/sys-apps/gsmartcontrol/gsmartcontrol-1.1.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic gnome2-utils
+
+DESCRIPTION="Hard disk drive health inspection tool"
+HOMEPAGE="https://gsmartcontrol.sourceforge.io/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 GPL-3 ) Boost-1.0 BSD Unlicense ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND="
+ dev-cpp/gtkmm:3.0
+ dev-libs/libpcre:3
+ sys-apps/smartmontools
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/xmessage
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/gtk-builder-convert )
+"
+
+DOCS="TODO" # See 'dist_doc_DATA' value in Makefile.am
+
+src_prepare() {
+ default
+ append-cxxflags -std=c++11
+}
+
+src_configure() {
+ econf $(use test tests)
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/share/doc/${PF}/LICENSE_* || die
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }