summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-11-03 21:47:59 -0400
committerMike Gilbert <floppym@gentoo.org>2016-11-03 21:48:13 -0400
commit2257d1f32b6301fd4f232e6c8e7667aa81169c24 (patch)
tree15e6c0bc5e9ea36fb38538bc09fba05a1f5604d6 /sys-apps/hwids/hwids-99999999.ebuild
parentdev-games/openscenegraph: stabilize 3.2.1-r2, fixed bug 589168 (diff)
downloadgentoo-2257d1f32b6301fd4f232e6c8e7667aa81169c24.tar.gz
gentoo-2257d1f32b6301fd4f232e6c8e7667aa81169c24.tar.bz2
gentoo-2257d1f32b6301fd4f232e6c8e7667aa81169c24.zip
sys-apps/hwids: bump to 20161103
Package-Manager: portage-2.3.2_p4
Diffstat (limited to 'sys-apps/hwids/hwids-99999999.ebuild')
-rw-r--r--sys-apps/hwids/hwids-99999999.ebuild31
1 files changed, 16 insertions, 15 deletions
diff --git a/sys-apps/hwids/hwids-99999999.ebuild b/sys-apps/hwids/hwids-99999999.ebuild
index 3ed137f0c8a3..2b7cac3cf656 100644
--- a/sys-apps/hwids/hwids-99999999.ebuild
+++ b/sys-apps/hwids/hwids-99999999.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
inherit udev eutils
DESCRIPTION="Hardware (PCI, USB, OUI, IAB) IDs databases"
HOMEPAGE="https://github.com/gentoo/hwids"
if [[ ${PV} == "99999999" ]]; then
+ inherit git-r3
EGIT_REPO_URI="${HOMEPAGE}.git"
- inherit git-2
else
SRC_URI="${HOMEPAGE}/archive/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux"
@@ -27,20 +27,23 @@ DEPEND="udev? (
RDEPEND="!<sys-apps/pciutils-3.1.9-r2
!<sys-apps/usbutils-005-r1"
-S=${WORKDIR}/hwids-${P}
+if [[ ${PV} != 99999999 ]]; then
+ S=${WORKDIR}/hwids-${P}
+fi
-src_prepare() {
- [[ ${PV} == "99999999" ]] && emake fetch
+src_unpack() {
+ if [[ ${PV} == 99999999 ]]; then
+ git-r3_src_unpack
+ cd "${S}" || die
+ emake fetch
+ else
+ default
+ fi
+}
+src_prepare() {
+ default
sed -i -e '/udevadm hwdb/d' Makefile || die
-
- # Create a rules file compatible with older udev.
- sed -e 's/evdev:name/keyboard:name/' \
- -e 's/evdev:atkbd:dmi/keyboard:dmi/' \
- -e 's/evdev:input:b\([^v]*\)v\([^p]*\)p\([^e]*\)\(e.*\)\?/keyboard:usb:v\2p\3/' \
- -e 's/keyboard:usb:v046DpC52D\*/keyboard:usb:v046DpC52Dd*dc*dsc*dp*ic*isc*ip*in00*/' \
- -e 's/keyboard:usb:v0458p0708\*/keyboard:usb:v0458p0708d*dc*dsc*dp*ic*isc*ip*in01*/' \
- udev/60-keyboard.hwdb > udev/61-oldkeyboard.hwdb || die
}
_emake() {
@@ -67,7 +70,5 @@ src_install() {
pkg_postinst() {
if use udev; then
udevadm hwdb --update --root="${ROOT%/}"
- # https://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
- [ "${ROOT:-/}" = "/" ] && udevadm control --reload
fi
}