summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-09 15:31:10 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-09 15:31:20 +0100
commitafe0bf46ddf20c0b3c1bce8ff8ffc5a90fa5070b (patch)
treeadfeeb82df0107f9e4fecdced029c9dfe72f53f1 /sys-apps/hwinfo/hwinfo-21.23.ebuild
parentdev-python/pyzmq: Freshly cythonize source (diff)
downloadgentoo-afe0bf46ddf20c0b3c1bce8ff8ffc5a90fa5070b.tar.gz
gentoo-afe0bf46ddf20c0b3c1bce8ff8ffc5a90fa5070b.tar.bz2
gentoo-afe0bf46ddf20c0b3c1bce8ff8ffc5a90fa5070b.zip
sys-apps/hwinfo: Version Bump
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=565300 Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-apps/hwinfo/hwinfo-21.23.ebuild')
-rw-r--r--sys-apps/hwinfo/hwinfo-21.23.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-apps/hwinfo/hwinfo-21.23.ebuild b/sys-apps/hwinfo/hwinfo-21.23.ebuild
new file mode 100644
index 000000000000..f656fe015bf7
--- /dev/null
+++ b/sys-apps/hwinfo/hwinfo-21.23.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit multilib rpm toolchain-funcs
+
+DESCRIPTION="Hardware detection tool used in SuSE Linux"
+HOMEPAGE="http://www.opensuse.org/"
+SRC_URI="http://download.opensuse.org/source/factory/repo/oss/suse/src/${P}-1.2.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ amd64? ( dev-libs/libx86emu )
+ x86? ( dev-libs/libx86emu )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ >=sys-kernel/linux-headers-2.6.17"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_prepare() {
+ # Respect AR variable.
+ sed -i \
+ -e 's:ar r:$(AR) r:' \
+ src/{,isdn,ids,smp,hd}/Makefile || die
+
+ # Respect LDFLAGS.
+ sed -i -e 's:$(CC) $(CFLAGS):$(CC) $(LDFLAGS) $(CFLAGS):' src/ids/Makefile || die
+
+ # Respect MAKE variable. Skip forced -pipe and -g. Respect LDFLAGS.
+ sed -i \
+ -e 's:make:$(MAKE):' \
+ -e 's:-pipe -g::' \
+ -e 's:LDFLAGS.*=:LDFLAGS +=:' \
+ Makefile{,.common} || die
+}
+
+src_compile() {
+ tc-export AR
+ emake CC="$(tc-getCC)" RPM_OPT_FLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
+
+ dodoc changelog README
+ doman doc/*.{1,8}
+ insinto /usr/share/doc/${PF}/examples
+ doins doc/example*.c
+}