summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/hwloc/hwloc-1.10.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/hwloc/hwloc-1.10.0.ebuild')
-rw-r--r--sys-apps/hwloc/hwloc-1.10.0.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/sys-apps/hwloc/hwloc-1.10.0.ebuild b/sys-apps/hwloc/hwloc-1.10.0.ebuild
new file mode 100644
index 000000000000..7820cb16d767
--- /dev/null
+++ b/sys-apps/hwloc/hwloc-1.10.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic cuda autotools-utils multilib versionator
+
+MY_PV=v$(get_version_component_range 1-2)
+
+DESCRIPTION="displays the hardware topology in convenient formats"
+HOMEPAGE="http://www.open-mpi.org/projects/hwloc/"
+SRC_URI="http://www.open-mpi.org/software/${PN}/${MY_PV}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="cairo cuda debug gl +numa opencl +pci plugins svg static-libs xml X"
+
+# TODO opencl only works with AMD so no virtual
+
+RDEPEND="sys-libs/ncurses
+ cairo? ( x11-libs/cairo[X?,svg?] )
+ cuda? ( dev-util/nvidia-cuda-toolkit )
+ gl? ( media-video/nvidia-settings )
+ opencl? ( x11-drivers/ati-drivers )
+ pci? (
+ sys-apps/pciutils
+ x11-libs/libpciaccess
+ )
+ plugins? ( sys-devel/libtool )
+ numa? ( sys-process/numactl )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README VERSION )
+
+PATCHES=( "${FILESDIR}/${PN}-1.8.1-gl.patch" )
+AUTOTOOLS_AUTORECONF=1
+
+src_prepare() {
+ if use cuda ; then
+ append-cflags -I/opt/cuda/include
+ append-cppflags -I/opt/cuda/include
+ append-ldflags -L/opt/cuda/$(get_libdir)
+ fi
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ export HWLOC_PKG_CONFIG=$(tc-getPKG_CONFIG) #393467
+ local myeconfargs=(
+ --disable-silent-rules
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable cairo)
+ $(use_enable cuda)
+ $(use_enable debug)
+ $(use_enable gl)
+ $(use_enable opencl)
+ $(use_enable pci)
+ $(use_enable plugins)
+ $(use_enable numa libnuma)
+ $(use_enable xml libxml2)
+ $(use_with X x)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+}