summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-04-21 20:32:10 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-04-21 20:32:54 +0300
commit64095b1dfcc2d960025fd5accd3fe8d96d6431d2 (patch)
treebfb191086993ae9db8ba492c473b1a72e68e9c66 /sys-apps/i2c-tools/i2c-tools-4.0.ebuild
parentx11-wm/awesome: update 9999 ebuild (diff)
downloadgentoo-64095b1dfcc2d960025fd5accd3fe8d96d6431d2.tar.gz
gentoo-64095b1dfcc2d960025fd5accd3fe8d96d6431d2.tar.bz2
gentoo-64095b1dfcc2d960025fd5accd3fe8d96d6431d2.zip
sys-apps/i2c-tools: respect AR/CFLAGS
Closes: https://bugs.gentoo.org/651528 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-apps/i2c-tools/i2c-tools-4.0.ebuild')
-rw-r--r--sys-apps/i2c-tools/i2c-tools-4.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-apps/i2c-tools/i2c-tools-4.0.ebuild b/sys-apps/i2c-tools/i2c-tools-4.0.ebuild
index 32dffbf1e2ba..3cd2a7f55086 100644
--- a/sys-apps/i2c-tools/i2c-tools-4.0.ebuild
+++ b/sys-apps/i2c-tools/i2c-tools-4.0.ebuild
@@ -32,9 +32,9 @@ src_configure() {
}
src_compile() {
- emake all-lib CC=$(tc-getCC) # parallel make
+ emake all-lib AR=$(tc-getAR) CC=$(tc-getCC) # parallel make
emake CC=$(tc-getCC)
- emake -C eepromer CC=$(tc-getCC)
+ emake -C eepromer CC=$(tc-getCC) CFLAGS="${CFLAGS}"
if use python ; then
cd py-smbus || die
append-cppflags -I../include
@@ -45,7 +45,7 @@ src_compile() {
src_install() {
emake install-lib install libdir="${D}"/usr/$(get_libdir) prefix="${D}"/usr
dosbin eepromer/eeprom{,er}
- rm -rf "${D}"/usr/include # part of linux-headers
+ rm -rf "${D}"/usr/include || die # part of linux-headers
dodoc CHANGES README
local d
for d in eeprom eepromer ; do