summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-21 22:43:02 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-21 22:46:29 -0800
commit2f78a1d9ea0c7c7d122fc6c6e1634e84c535d763 (patch)
tree4c38cbbef31a9547b3d0eb48397b0acb049d1f3e /sys-apps/ibm-powerpc-utils/ibm-powerpc-utils-1.3.7.ebuild
parentdev-lang/erlang: Update virtual/emacs dependency (again). (diff)
downloadgentoo-2f78a1d9ea0c7c7d122fc6c6e1634e84c535d763.tar.gz
gentoo-2f78a1d9ea0c7c7d122fc6c6e1634e84c535d763.tar.bz2
gentoo-2f78a1d9ea0c7c7d122fc6c6e1634e84c535d763.zip
sys-apps/ibm-powerpc-utils: bump to 1.3.7
Also switch to GPL-2+ license Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-apps/ibm-powerpc-utils/ibm-powerpc-utils-1.3.7.ebuild')
-rw-r--r--sys-apps/ibm-powerpc-utils/ibm-powerpc-utils-1.3.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/ibm-powerpc-utils/ibm-powerpc-utils-1.3.7.ebuild b/sys-apps/ibm-powerpc-utils/ibm-powerpc-utils-1.3.7.ebuild
new file mode 100644
index 000000000000..37767f844b18
--- /dev/null
+++ b/sys-apps/ibm-powerpc-utils/ibm-powerpc-utils-1.3.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Utilities for the maintainance of the IBM and Apple PowerPC platforms"
+HOMEPAGE="https://github.com/ibm-power-utilities/powerpc-utils"
+SRC_URI="https://github.com/ibm-power-utilities/${PN//ibm-}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="+rtas"
+
+S="${WORKDIR}/${P//ibm-}"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~ppc ~ppc64"
+
+DEPEND="
+ sys-devel/bc
+"
+RDEPEND="
+ ${DEPEND}
+ !sys-apps/powerpc-utils
+ rtas? ( >=sys-libs/librtas-2.0.2 )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.5-docdir.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with rtas librtas)
+}