summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-04-29 06:49:41 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-04-29 07:11:58 -0400
commit651c0e61444d9438f85fd6b9f0095bbb14076e88 (patch)
treeb509da08c806dff2ff2cdca3ce884d2e1b051ca1 /sys-apps/install-xattr/install-xattr-9999.ebuild
parentdev-lang/ekopath: Snapshot bump (diff)
downloadgentoo-651c0e61444d9438f85fd6b9f0095bbb14076e88.tar.gz
gentoo-651c0e61444d9438f85fd6b9f0095bbb14076e88.tar.bz2
gentoo-651c0e61444d9438f85fd6b9f0095bbb14076e88.zip
sys-apps/install-xattr: cleanup how we do PREFIX and bump to EAPI=6
Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-apps/install-xattr/install-xattr-9999.ebuild')
-rw-r--r--sys-apps/install-xattr/install-xattr-9999.ebuild28
1 files changed, 19 insertions, 9 deletions
diff --git a/sys-apps/install-xattr/install-xattr-9999.ebuild b/sys-apps/install-xattr/install-xattr-9999.ebuild
index 7ebd6fac3c6d..d64e0c47d619 100644
--- a/sys-apps/install-xattr/install-xattr-9999.ebuild
+++ b/sys-apps/install-xattr/install-xattr-9999.ebuild
@@ -1,23 +1,21 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
+
DESCRIPTION="Wrapper to coreutil's install to preserve Filesystem Extended Attributes"
HOMEPAGE="https://dev.gentoo.org/~blueness/install-xattr/"
inherit toolchain-funcs
-S="${WORKDIR}/${PN}"
-
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://anongit.gentoo.org/proj/elfix.git"
- EGIT_CHECKOUT_DIR="${S}"
- S+=/misc/${PN}
- inherit git-r3
+ inherit git-2
else
SRC_URI="https://dev.gentoo.org/~blueness/install-xattr/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ S=${WORKDIR}/${PN}
fi
LICENSE="GPL-3"
@@ -25,11 +23,23 @@ SLOT="0"
src_prepare() {
tc-export CC
- sed -e "s|^\\(PREFIX = \\)\\(/usr\\)$|\\1${EPREFIX}\\2|" \
- -i Makefile || die "sed Makefile failed"
+}
+
+src_compile() {
+ if [[ ${PV} == "9999" ]] ; then
+ cd "${WORKDIR}/${P}/misc/${PN}" || die
+ fi
+ default
+}
+
+src_install() {
+ if [[ ${PV} == "9999" ]] ; then
+ cd "${WORKDIR}/${P}/misc/${PN}" || die
+ fi
+ DESTDIR=${ED} emake install
}
# We need to fix how tests are done
src_test() {
- return 0
+ true
}