summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2017-09-07 23:16:31 +0200
committerJonas Stein <jstein@gentoo.org>2017-09-07 23:17:22 +0200
commit907449148a6ad8d40235c5c97c840ff90aba3a16 (patch)
tree19fbf6f61698014cb63a2d951e9bc2df9012e633 /sys-apps/inxi/inxi-2.3.37.ebuild
parentsys-auth/google-authenticator: Revision bump to distribute latest changes (diff)
downloadgentoo-907449148a6ad8d40235c5c97c840ff90aba3a16.tar.gz
gentoo-907449148a6ad8d40235c5c97c840ff90aba3a16.tar.bz2
gentoo-907449148a6ad8d40235c5c97c840ff90aba3a16.zip
sys-apps/inxi: Version bump to 2.3.37
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sys-apps/inxi/inxi-2.3.37.ebuild')
-rw-r--r--sys-apps/inxi/inxi-2.3.37.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-apps/inxi/inxi-2.3.37.ebuild b/sys-apps/inxi/inxi-2.3.37.ebuild
new file mode 100644
index 000000000000..1784750cd366
--- /dev/null
+++ b/sys-apps/inxi/inxi-2.3.37.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_COMMIT="2b4e89b21ffd06e888d89a38aaedb797ecea4403"
+# ^^ because upstream refuses to tag commits with version numbers
+
+DESCRIPTION="The CLI inxi collects and prints hardware and system information"
+HOMEPAGE="https://github.com/smxi/inxi"
+SRC_URI="https://github.com/smxi/${PN}/tarball/${MY_COMMIT} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-shells/bash-3.0
+ sys-apps/pciutils
+ sys-apps/usbutils
+ "
+S="${WORKDIR}/smxi-${PN}-${MY_COMMIT:0:7}"
+
+src_install() {
+ dobin "${PN}"
+ unpack "./${PN}.1.gz"
+ doman "${PN}.1"
+}