summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2017-11-04 23:53:08 +0100
committerJonas Stein <jstein@gentoo.org>2017-11-04 23:53:38 +0100
commitd73cf753a4c418f181e52fc118ee2a193bd67f5a (patch)
tree9ddea54a1221c2c3ae6ab65aee1ff9f9cfb9a0cc /sys-apps/inxi/inxi-2.3.43.ebuild
parentwww-client/chromium: dev channel bump (64.0.3253.3) (diff)
downloadgentoo-d73cf753a4c418f181e52fc118ee2a193bd67f5a.tar.gz
gentoo-d73cf753a4c418f181e52fc118ee2a193bd67f5a.tar.bz2
gentoo-d73cf753a4c418f181e52fc118ee2a193bd67f5a.zip
sys-apps/inxi: Bump to 2.3.43 and add use flags
Version bump to 2.3.43 Support the global use flags bluetooth, hddtemp and opengl. Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'sys-apps/inxi/inxi-2.3.43.ebuild')
-rw-r--r--sys-apps/inxi/inxi-2.3.43.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/inxi/inxi-2.3.43.ebuild b/sys-apps/inxi/inxi-2.3.43.ebuild
new file mode 100644
index 000000000000..d970013c44ce
--- /dev/null
+++ b/sys-apps/inxi/inxi-2.3.43.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_COMMIT="0e7227d25cbf9e83f7fc6af5e1bcb919855f9ecf"
+# ^^ because upstream refuses to tag commits with version numbers
+
+DESCRIPTION="The CLI inxi collects and prints hardware and system information"
+HOMEPAGE="https://github.com/smxi/inxi"
+SRC_URI="https://github.com/smxi/${PN}/tarball/${MY_COMMIT} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="bluetooth hddtemp opengl"
+
+DEPEND=""
+RDEPEND=">=app-shells/bash-3.0
+ sys-apps/pciutils
+ sys-apps/usbutils
+ bluetooth? ( net-wireless/bluez )
+ hddtemp? ( app-admin/hddtemp )
+ opengl? ( x11-apps/mesa-progs )
+ "
+
+S="${WORKDIR}/smxi-${PN}-${MY_COMMIT:0:7}"
+
+src_install() {
+ dobin ${PN}
+ unpack ./${PN}.1.gz
+ doman ${PN}.1
+}