summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2020-08-22 16:01:49 +0200
committerJonas Stein <jstein@gentoo.org>2020-08-22 16:01:49 +0200
commitd624ba610d93096e322354dbe7c792787855de39 (patch)
tree78f6846bea1160754332604f0a8a8898c8ebfc2e /sys-apps/inxi
parentprofiles/package.mask: Unmask net-dns/dnsviz (diff)
downloadgentoo-d624ba610d93096e322354dbe7c792787855de39.tar.gz
gentoo-d624ba610d93096e322354dbe7c792787855de39.tar.bz2
gentoo-d624ba610d93096e322354dbe7c792787855de39.zip
sys-apps/inxi: Version bump to 3.1.06-1
Just a version bump to 3.1.06-1 Package-Manager: Portage-3.0.3, Repoman-2.3.23 Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'sys-apps/inxi')
-rw-r--r--sys-apps/inxi/Manifest1
-rw-r--r--sys-apps/inxi/inxi-3.1.06.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/inxi/Manifest b/sys-apps/inxi/Manifest
index 4f7cf38fec1b..15f915a5b6bb 100644
--- a/sys-apps/inxi/Manifest
+++ b/sys-apps/inxi/Manifest
@@ -2,3 +2,4 @@ DIST inxi-3.0.33.1.tar.gz 306370 BLAKE2B 9ebd8d6e00fe241d5fdf52ddbfc01bdb03682f1
DIST inxi-3.0.34.1.tar.gz 308373 BLAKE2B 290a0887a7885b040f614140a99cbd7e0a8f8b89943e2f39cf00f033fb88fbe6a65dd4b5848f4ff7758f5fe81112404abef6102c44f4732308cda0e4ce887766 SHA512 cfc221ce5cd87dd2418ef0a6f916b17ed4a90aa9c6485ffc40a37d87d337f18d1ad98ae53fa366dc56b5250f2e95dc14c528b14d8f796b6d1b26b982cbf0b22b
DIST inxi-3.0.36.1.tar.gz 311680 BLAKE2B 95c9ab57a9af50ace8fdacebb42a94017b1506a9215f8f70ff35f281dd207685d570fe257abc5446b57dd9b9a7ce28e568a4ebf9d664731dde437a6cfd64647f SHA512 1b242878b9a5180ed63dedcac7381ce41380a1bd95ba7f85bfb2c97b635fdc7700162373078963ef708fa5cd47084aa6f5c71b212042fe1acd87e01a85599296
DIST inxi-3.0.38.1.tar.gz 320672 BLAKE2B 9c486ee07db4abad47c767c2f0d27d5e7c30e6640c50062c986f36201dce5217babd487a2d8f516be2d9bc41b8a06137d94ccb560fa0996d9a660a26004ef18d SHA512 44f97474a130f2b932c0ee54658673846712305bf2fb738c293514f62df1ca2c5d11688e2557a3f6eaeb933db0fed904e818e3dda28b839baa3ac89e6385d3a2
+DIST inxi-3.1.06.1.tar.gz 357819 BLAKE2B e6eb8a34807323d7f46ff029af797e3a13229813bf0cff4b8b874cd21ff1d38459e2181ddf3882b4ee0d29e8c788e2fce1c01f5c295911493292082192c56c2b SHA512 6621252048e95132cfec30e341f72f5942188f273488509614aab28e55ee9987b8f3820e1298c4d9a16b4f3464f1f270fb4c1d5e5a7bf0d2f616b4180193ab6b
diff --git a/sys-apps/inxi/inxi-3.1.06.1.ebuild b/sys-apps/inxi/inxi-3.1.06.1.ebuild
new file mode 100644
index 000000000000..9f446bf4dc90
--- /dev/null
+++ b/sys-apps/inxi/inxi-3.1.06.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=$(ver_rs 3 '-')
+# 2.3.56 was the last version with no tagged release.
+# It was also the last Bash based release. Later versions are Perl based
+
+DESCRIPTION="The CLI inxi collects and prints hardware and system information"
+HOMEPAGE="https://github.com/smxi/inxi"
+SRC_URI="https://github.com/smxi/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="bluetooth hddtemp opengl"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ sys-apps/pciutils
+ sys-apps/usbutils
+ bluetooth? ( net-wireless/bluez )
+ hddtemp? ( app-admin/hddtemp )
+ opengl? ( x11-apps/mesa-progs )
+ "
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}