summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-15 01:29:58 +0000
committerSam James <sam@gentoo.org>2023-03-15 01:51:05 +0000
commitf28e56c8a6fc725ff65d68207e9d2234e9f40273 (patch)
tree48982e61f2e141980b037fedb309463a75800a77 /sys-apps/ipmiutil
parentsci-mathematics/coq-serapi: introduce COQ_MIN_V (diff)
downloadgentoo-f28e56c8a6fc725ff65d68207e9d2234e9f40273.tar.gz
gentoo-f28e56c8a6fc725ff65d68207e9d2234e9f40273.tar.bz2
gentoo-f28e56c8a6fc725ff65d68207e9d2234e9f40273.zip
sys-apps/ipmiutil: add 3.1.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/ipmiutil')
-rw-r--r--sys-apps/ipmiutil/Manifest1
-rw-r--r--sys-apps/ipmiutil/ipmiutil-3.1.9.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/sys-apps/ipmiutil/Manifest b/sys-apps/ipmiutil/Manifest
index c01f03c91695..d0c8eb29fdbf 100644
--- a/sys-apps/ipmiutil/Manifest
+++ b/sys-apps/ipmiutil/Manifest
@@ -1 +1,2 @@
DIST ipmiutil-3.1.8.tar.gz 1841037 BLAKE2B 69139fc2b82a701657c5fec6aa928a0ee2d7874a8ebc26631eca438f298e8bddd3afb578462979eb24cd51bd816263f13e9f38fec8b5d6fa4fcefb2519a652c9 SHA512 77a01be420d8362ddce2b2b2bd44ee53a70812b29b3dd7bc5add6429f0e43a48905ca0401e1855f2cca5e69086605eb7b84e2f4bf9cf33251934acc0fe51346f
+DIST ipmiutil-3.1.9.tar.gz 1876478 BLAKE2B ddbd4d91d1d09fd9a7d4f7a3f9358787cab1baf3e2f34e43b4ebf44843d9ccc8d8b241b030d0f62a4b183ac4642c6676b304a51b8c6611f69d475dd19c1d3181 SHA512 3c9f60669dd6769dc64977c99d68fc0a0838993fb5ef3d8b1b1026b6daf6e6bfbe8738f3dd120b116fc663c84bafe6ed93420a92fecf57a17785d283b415d9c7
diff --git a/sys-apps/ipmiutil/ipmiutil-3.1.9.ebuild b/sys-apps/ipmiutil/ipmiutil-3.1.9.ebuild
new file mode 100644
index 000000000000..b69658bea04e
--- /dev/null
+++ b/sys-apps/ipmiutil/ipmiutil-3.1.9.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd
+
+DESCRIPTION="IPMI Management Utilities"
+HOMEPAGE="http://ipmiutil.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/openssl-1:="
+DEPEND="
+ ${RDEPEND}
+ virtual/os-headers
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.9.9-lib_symlink.patch
+ "${FILESDIR}"/${PN}-3.1.8-fix-configure.patch
+)
+
+src_prepare() {
+ default
+
+ # Fix hardcoded CFLAGS
+ sed -i \
+ -e 's|-O2 -g|$(CFLAGS)|g' \
+ -e 's|-g -O2|$(CFLAGS)|g' \
+ util/Makefile.am* || die
+
+ # The configure script makes some guarded and some blind calls to rpm &
+ # rpmbuild, that trigger sandbox warnings if rpm is installed in Gentoo.
+ sed -r -i -e 's/which rpm/false &/' configure.ac || die
+ sed -r -i -e 's/`(rpm|rpmbuild)/`false \1/' configure.ac || die
+ # Don't try to inject -O2 or hardening flags (which we set in the toolchain).
+ sed -i -e '/CFLAGS="-O2"/d' -e '/cfhard=/d' configure.ac || die
+
+ # Don't compress man pages
+ sed '/gzip -nf/d' -i doc/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-systemd
+ --enable-sha256
+ --enable-lanplus
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # Ugly workaround. Upstream is misusing the make system here
+ # and it doesn't even work.
+ # Please check on each bump if this workaround is still required.
+ # Yup, still needed in 3.18
+ pushd lib/lanplus &>/dev/null || die
+ emake
+ cp libipmi_lanplus.a .. || die
+ popd &>/dev/null || die
+
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" sysdto="${D}/$(systemd_get_systemunitdir)" install
+ dodoc -r AUTHORS ChangeLog NEWS README TODO doc/UserGuide
+
+ # Init scripts are only for Fedora
+ # TODO: ship OpenRC systems for non-systemd?
+ rm -r "${ED}"/etc/init.d || die 'remove initscripts failed'
+
+ # --disable-static has no effect
+ if ! use static-libs ; then
+ find "${ED}" -type f -name '*.a' -delete || die
+ fi
+
+ keepdir /var/lib/ipmiutil
+}