summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-11-22 13:08:18 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2017-11-22 14:25:09 -0800
commit6f267bc0727e3d886323497f8a741cf97b193b0a (patch)
tree1fb1b7df1e90bfe17f34f84e5241cc1ec24f2076 /sys-apps/iproute2/iproute2-4.5.0.ebuild
parentsys-apps/openrc: stable 0.34.9 on hppa for bug #631958 (diff)
downloadgentoo-6f267bc0727e3d886323497f8a741cf97b193b0a.tar.gz
gentoo-6f267bc0727e3d886323497f8a741cf97b193b0a.tar.bz2
gentoo-6f267bc0727e3d886323497f8a741cf97b193b0a.zip
sys-apps/iproute2: fix automagic libelf dep.
iproute2 has been automagically linking against libelf for a long time. It is only used for eBPF programs, so isn't critical in most cases. Declare the dep via virtual/libelf, but put it behind USE=-minimal, as with libmnl. Closes: https://bugs.gentoo.org/638282 Package-Manager: Portage-2.3.8, Repoman-2.3.3 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'sys-apps/iproute2/iproute2-4.5.0.ebuild')
-rw-r--r--sys-apps/iproute2/iproute2-4.5.0.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sys-apps/iproute2/iproute2-4.5.0.ebuild b/sys-apps/iproute2/iproute2-4.5.0.ebuild
index 2d253c67279d..49cf0f5b2ccf 100644
--- a/sys-apps/iproute2/iproute2-4.5.0.ebuild
+++ b/sys-apps/iproute2/iproute2-4.5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -22,7 +22,7 @@ IUSE="atm berkdb +iptables ipv6 minimal selinux"
# We could make libmnl optional, but it's tiny, so eh
RDEPEND="!net-misc/arpd
- !minimal? ( net-libs/libmnl )
+ !minimal? ( net-libs/libmnl virtual/libelf )
iptables? ( >=net-firewall/iptables-1.4.20:= )
berkdb? ( sys-libs/db:= )
atm? ( net-dialup/linux-atm )
@@ -81,6 +81,7 @@ src_configure() {
TC_CONFIG_IPSET := y
HAVE_BERKELEY_DB := $(usex berkdb y n)
HAVE_MNL := $(usex minimal n y)
+ HAVE_ELF := $(usex minimal n y)
HAVE_SELINUX := $(usex selinux y n)
IP_CONFIG_SETNS := ${setns}
# Use correct iptables dir, #144265 #293709