summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-01-07 16:31:46 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2017-01-07 16:32:50 -0800
commit932b155bb612154a81654a5b23b9c59bf7768258 (patch)
tree82521cb2111add15789bdff519fd0cb2dad91260 /sys-apps/kexec-tools/kexec-tools-2.0.13-r1.ebuild
parentapp-editors/ghostwriter: 1.4.2 version bump, fix DEPENDs, APPVERSION (diff)
downloadgentoo-932b155bb612154a81654a5b23b9c59bf7768258.tar.gz
gentoo-932b155bb612154a81654a5b23b9c59bf7768258.tar.bz2
gentoo-932b155bb612154a81654a5b23b9c59bf7768258.zip
sys-apps/kexec-tools: support more kernel names.
Package-Manager: portage-2.3.2 Gentoo-Bug: 489864 Fixes: https://bugs.gentoo.org/show_bug.cgi?id=489864 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'sys-apps/kexec-tools/kexec-tools-2.0.13-r1.ebuild')
-rw-r--r--sys-apps/kexec-tools/kexec-tools-2.0.13-r1.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/sys-apps/kexec-tools/kexec-tools-2.0.13-r1.ebuild b/sys-apps/kexec-tools/kexec-tools-2.0.13-r1.ebuild
new file mode 100644
index 000000000000..8bc203d65eb1
--- /dev/null
+++ b/sys-apps/kexec-tools/kexec-tools-2.0.13-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/kernel/kexec/kexec-tools.git"
+ AUTOTOOLS_AUTORECONF=true
+else
+ SRC_URI="mirror://kernel/linux/utils/kernel/kexec/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit autotools-utils linux-info systemd
+
+DESCRIPTION="Load another kernel from the currently executing Linux kernel"
+HOMEPAGE="https://kernel.org/pub/linux/utils/kernel/kexec/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="booke lzma xen zlib"
+
+REQUIRED_USE="lzma? ( zlib )"
+
+DEPEND="
+ lzma? ( app-arch/xz-utils )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~KEXEC"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.4-disable-kexec-test.patch
+ "${FILESDIR}"/${PN}-2.0.4-out-of-source.patch
+)
+
+pkg_setup() {
+ # GNU Make's $(COMPILE.S) passes ASFLAGS to $(CCAS), CCAS=$(CC)
+ export ASFLAGS="${CCASFLAGS}"
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with booke)
+ $(use_with lzma)
+ $(use_with xen)
+ $(use_with zlib)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ dodoc "${FILESDIR}"/README.Gentoo
+
+ newinitd "${FILESDIR}"/kexec.init-2.0.13-r1 kexec
+ newconfd "${FILESDIR}"/kexec.conf-2.0.4 kexec
+
+ insinto /etc
+ doins "${FILESDIR}"/kexec.conf
+
+ insinto /etc/kernel/postinst.d
+ doins "${FILESDIR}"/90_kexec
+
+ systemd_dounit "${FILESDIR}"/kexec.service
+}
+
+pkg_postinst() {
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ elog "For systemd support the new config file is"
+ elog " /etc/kexec.conf"
+ elog "Please adopt it to your needs as there is no autoconfig anymore"
+ fi
+}