summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-08-29 00:44:38 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-08-29 00:45:05 +0200
commit07e7a6078533daa2ef86769c29c28966acd62470 (patch)
tree35285baf478710b70c9f7745d09cfd4503b17b6e /sys-apps/kexec-tools/kexec-tools-2.0.17-r1.ebuild
parentsys-devel/clang: Fix unpacking libTestingSupport (diff)
downloadgentoo-07e7a6078533daa2ef86769c29c28966acd62470.tar.gz
gentoo-07e7a6078533daa2ef86769c29c28966acd62470.tar.bz2
gentoo-07e7a6078533daa2ef86769c29c28966acd62470.zip
sys-apps/kexec-tools: fix "Unhandled rela relocation: R_X86_64_PLT32" error
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'sys-apps/kexec-tools/kexec-tools-2.0.17-r1.ebuild')
-rw-r--r--sys-apps/kexec-tools/kexec-tools-2.0.17-r1.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/sys-apps/kexec-tools/kexec-tools-2.0.17-r1.ebuild b/sys-apps/kexec-tools/kexec-tools-2.0.17-r1.ebuild
new file mode 100644
index 000000000000..fdf796648713
--- /dev/null
+++ b/sys-apps/kexec-tools/kexec-tools-2.0.17-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/utils/kernel/kexec/kexec-tools.git"
+else
+ SRC_URI="mirror://kernel/linux/utils/kernel/kexec/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+inherit flag-o-matic libtool linux-info systemd
+
+DESCRIPTION="Load another kernel from the currently executing Linux kernel"
+HOMEPAGE="https://kernel.org/pub/linux/utils/kernel/kexec/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="booke lzma xen zlib"
+
+REQUIRED_USE="lzma? ( zlib )"
+
+DEPEND="
+ lzma? ( app-arch/xz-utils )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~KEXEC"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.4-disable-kexec-test.patch
+ "${FILESDIR}"/${PN}-2.0.4-out-of-source.patch
+ "${FILESDIR}"/${P}-fix-unhandled-rela-relocation-R_X86_64_PLT32-error.patch
+)
+
+pkg_setup() {
+ # GNU Make's $(COMPILE.S) passes ASFLAGS to $(CCAS), CCAS=$(CC)
+ export ASFLAGS="${CCASFLAGS}"
+}
+
+src_prepare() {
+ default
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ else
+ elibtoolize
+ fi
+ filter-flags '-mindirect-branch=thunk*'
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with booke)
+ $(use_with lzma)
+ $(use_with xen)
+ $(use_with zlib)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ dodoc "${FILESDIR}"/README.Gentoo
+
+ newinitd "${FILESDIR}"/kexec.init-2.0.13-r1 kexec
+ newconfd "${FILESDIR}"/kexec.conf-2.0.4 kexec
+
+ insinto /etc
+ doins "${FILESDIR}"/kexec.conf
+
+ insinto /etc/kernel/postinst.d
+ doins "${FILESDIR}"/90_kexec
+
+ systemd_dounit "${FILESDIR}"/kexec.service
+}
+
+pkg_postinst() {
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ elog "For systemd support the new config file is"
+ elog " /etc/kexec.conf"
+ elog "Please adopt it to your needs as there is no autoconfig anymore"
+ fi
+}