summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-24 18:29:06 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-24 18:30:12 +0200
commit303e55e589bd914b48bfbc3e29880cfb2bac0c91 (patch)
tree38b4c56844f56a653cd9ef89960c89e988abbe26 /sys-apps/keyutils/files
parentsys-apps/collectl: Bump to version 4.1.3 (diff)
downloadgentoo-303e55e589bd914b48bfbc3e29880cfb2bac0c91.tar.gz
gentoo-303e55e589bd914b48bfbc3e29880cfb2bac0c91.tar.bz2
gentoo-303e55e589bd914b48bfbc3e29880cfb2bac0c91.zip
sys-apps/keyutils: Bump to version 1.5.10
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sys-apps/keyutils/files')
-rw-r--r--sys-apps/keyutils/files/keyutils-1.5.10-disable-tests.patch51
-rw-r--r--sys-apps/keyutils/files/keyutils-1.5.10-makefile-fixup.patch25
2 files changed, 76 insertions, 0 deletions
diff --git a/sys-apps/keyutils/files/keyutils-1.5.10-disable-tests.patch b/sys-apps/keyutils/files/keyutils-1.5.10-disable-tests.patch
new file mode 100644
index 000000000000..fa82792cddbd
--- /dev/null
+++ b/sys-apps/keyutils/files/keyutils-1.5.10-disable-tests.patch
@@ -0,0 +1,51 @@
+disable tests that mess with system wide settings
+
+https://bugs.gentoo.org/519062
+
+--- keyutils-1.5.10/tests/bugzillas/bz1031154/runtest.sh
++++ keyutils-1.5.10/tests/bugzillas/bz1031154/runtest.sh
+@@ -27,6 +27,8 @@
+
+ echo "++++ BEGINNING TEST" >$OUTPUTFILE
+
++if false ; then
++
+ # we need a reference time to scan the audit log from so as not to pick up old
+ # results from this test.
+ base_date=`date +"%x@%X"`
+@@ -97,6 +99,10 @@
+ fi
+ fi
+
++else
++marker "Gentoo: skipping test due to system wide modifications"
++fi
++
+ echo "++++ FINISHED TEST: $result" >>$OUTPUTFILE
+
+ # --- then report the results in the database ---
+
+https://bugs.gentoo.org/522050
+
+--- keyutils-1.5.10/tests/keyctl/padd/useradd/runtest.sh
++++ keyutils-1.5.10/tests/keyctl/padd/useradd/runtest.sh
+@@ -40,6 +40,8 @@
+ marker "UNLINK KEY"
+ unlink_key $keyid @s
+
++if false ; then
++
+ if [ $skip_root_required = 0 ] && {
+ [ $OSDIST = RHEL ] && ! version_less_than $OSRELEASE 6.6 ||
+ keyutils_at_or_later_than 1.5.6 ;
+@@ -85,6 +87,10 @@
+ fi
+ fi
+
++else
++marker "Gentoo: skipping test due to system wide modifications"
++fi
++
+ echo "++++ FINISHED TEST: $result" >>$OUTPUTFILE
+
+ # --- then report the results in the database ---
diff --git a/sys-apps/keyutils/files/keyutils-1.5.10-makefile-fixup.patch b/sys-apps/keyutils/files/keyutils-1.5.10-makefile-fixup.patch
new file mode 100644
index 000000000000..c37cca0dbfd7
--- /dev/null
+++ b/sys-apps/keyutils/files/keyutils-1.5.10-makefile-fixup.patch
@@ -0,0 +1,25 @@
+From 19b92eb56ca53cb4967e7bd27e3bc5e3b0e29736 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Thu, 16 Mar 2017 09:55:42 +0100
+Subject: [PATCH] depend on $(DEVELLIB) not -lkeyutils
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 824bbbf..8ce3a13 100644
+--- a/Makefile
++++ b/Makefile
+@@ -167,7 +167,7 @@ ifeq ($(NO_SOLIB),0)
+ $(INSTALL) -D $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(LIBNAME)
+ $(LNS) $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SONAME)
+ mkdir -p $(DESTDIR)$(USRLIBDIR)
+- $(LNS) $(LIBDIR)/$(SONAME) $(DESTDIR)$(USRLIBDIR)/$(DEVELLIB)
++ $(LNS) $(SONAME) $(DESTDIR)$(USRLIBDIR)/$(DEVELLIB)
+ endif
+ $(INSTALL) -D keyctl $(DESTDIR)$(BINDIR)/keyctl
+ $(INSTALL) -D request-key $(DESTDIR)$(SBINDIR)/request-key
+--
+2.12.0
+