summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-08-31 16:46:05 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-08-31 16:54:44 +0200
commit727929e2098f7f73a0c9fb1b9de8758c8658d870 (patch)
tree1cf7b11583fecb5316e4ef2682b29ff026e2391e /sys-apps/keyutils/keyutils-1.5.11-r1.ebuild
parentsys-apps/keyutils: tests require a kernel with KEY_DH_OPERATIONS (diff)
downloadgentoo-727929e2098f7f73a0c9fb1b9de8758c8658d870.tar.gz
gentoo-727929e2098f7f73a0c9fb1b9de8758c8658d870.tar.bz2
gentoo-727929e2098f7f73a0c9fb1b9de8758c8658d870.zip
sys-apps/keyutils: depend on app-crypt/mit-krb5 atom
Upstream added support for AFS SRV records [Link 1] which requires "profile.h" from app-crypt/mit-krb5 package. Link 1: https://git.kernel.org/pub/scm/linux/kernel/git/dhowells/keyutils.git/commit/?id=0d71523ab58493e1b40e1c80d569ff8ebc5ea27d Closes: https://bugs.gentoo.org/664942 Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'sys-apps/keyutils/keyutils-1.5.11-r1.ebuild')
-rw-r--r--sys-apps/keyutils/keyutils-1.5.11-r1.ebuild102
1 files changed, 102 insertions, 0 deletions
diff --git a/sys-apps/keyutils/keyutils-1.5.11-r1.ebuild b/sys-apps/keyutils/keyutils-1.5.11-r1.ebuild
new file mode 100644
index 000000000000..f4892d5ba5ab
--- /dev/null
+++ b/sys-apps/keyutils/keyutils-1.5.11-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit multilib toolchain-funcs linux-info multilib-minimal
+
+DESCRIPTION="Linux Key Management Utilities"
+HOMEPAGE="https://people.redhat.com/dhowells/keyutils/"
+SRC_URI="https://people.redhat.com/dhowells/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static static-libs test"
+
+RDEPEND=""
+DEPEND="app-crypt/mit-krb5
+ !prefix? ( >=sys-kernel/linux-headers-2.6.11 )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.10-endian-check-1.patch
+ "${FILESDIR}"/${PN}-1.5.10-makefile-fixup.patch
+ "${FILESDIR}"/${PN}-1.5.10-silence-rpm-check.patch #656446
+ "${FILESDIR}"/${PN}-1.5.10-disable-tests.patch #519062 #522050
+ "${FILESDIR}"/${PN}-1.5.9-header-extern-c.patch
+)
+
+pkg_setup() {
+ CONFIG_CHECK="~KEYS"
+ ERROR_KEYS="You must have CONFIG_KEYS to use this package!"
+
+ if use test && kernel_is lt 4 0 0; then
+ CONFIG_CHECK="${CONFIG_CHECK} ~KEYS_DEBUG_PROC_KEYS ~KEY_DH_OPERATIONS"
+ ERROR_KEYS_DEBUG_PROC_KEYS="You must have CONFIG_KEYS_DEBUG_PROC_KEYS to run the package testsuite!"
+ fi
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # The lsb check is useless, so avoid spurious command not found messages.
+ sed -i -e 's,lsb_release,:,' tests/prepare.inc.sh || die
+ # All the test files are bash, but try to execute via `sh`.
+ sed -i -r \
+ -e 's:([[:space:]])sh([[:space:]]):\1bash\2:' \
+ tests/{Makefile*,*.sh} || die
+ find tests/ -name '*.sh' -exec sed -i '1s:/sh$:/bash:' {} +
+ # Some tests call the kernel which calls userspace, but that will
+ # run the install keyutils rather than the locally compiled one,
+ # so disable round trip tests.
+ rm -rf tests/keyctl/requesting/{bad-args,piped,valid}
+
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ tc-export AR CC
+ sed -i \
+ -e "1iRPATH = $(usex static -static '')" \
+ -e '/^C.*FLAGS/s|:=|+=|' \
+ -e 's:-Werror::' \
+ -e '/^BUILDFOR/s:=.*:=:' \
+ -e "/^LIBDIR/s:=.*:= /usr/$(get_libdir):" \
+ -e '/^USRLIBDIR/s:=.*:=$(LIBDIR):' \
+ -e "s: /: ${EPREFIX}/:g" \
+ -e '/^NO_ARLIB/d' \
+ Makefile || die
+
+ # We need the static lib in order to statically link programs.
+ if use static ; then
+ export NO_ARLIB=0
+ # Hack the progs to depend on the static lib instead.
+ sed -i \
+ -e '/^.*:.*[$](DEVELLIB)$/s:$(DEVELLIB):$(ARLIB) $(SONAME):' \
+ Makefile || die
+ else
+ export NO_ARLIB=$(usex static-libs 0 1)
+ fi
+ emake
+}
+
+multilib_src_test() {
+ # Execute the locally compiled code rather than the
+ # older versions already installed in the system.
+ LD_LIBRARY_PATH=${BUILD_DIR} \
+ PATH="${BUILD_DIR}:${PATH}" \
+ emake test
+}
+
+multilib_src_install() {
+ # Possibly undo the setting for USE=static (see src_compile).
+ export NO_ARLIB=$(usex static-libs 0 1)
+
+ default
+ use static || gen_usr_ldscript -a keyutils
+}
+
+multilib_src_install_all() {
+ dodoc README
+}