summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/lkcdutils/lkcdutils-4.1.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/lkcdutils/lkcdutils-4.1.1.ebuild')
-rw-r--r--sys-apps/lkcdutils/lkcdutils-4.1.1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/sys-apps/lkcdutils/lkcdutils-4.1.1.ebuild b/sys-apps/lkcdutils/lkcdutils-4.1.1.ebuild
new file mode 100644
index 000000000000..47c6be3e553e
--- /dev/null
+++ b/sys-apps/lkcdutils/lkcdutils-4.1.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+MY_P=${P/4.1.1/4.1}
+DESCRIPTION="Linux Kernel Crash Dumps (LKCD) Utilities"
+HOMEPAGE="http://lkcd.sourceforge.net/ http://oss.software.ibm.com/developerworks/opensource/linux390/june2003_recommended.shtml"
+SRC_URI="http://lkcd.sourceforge.net/download/OLD/4.1.1/lkcdutils/lkcdutils-4.1-1.src.rpm
+ mirror://gentoo/lkcdutils-4.1-savedump.tar.gz
+ mirror://gentoo/lkcdutils-4.1-dhv8.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="s390"
+IUSE=""
+
+DEPEND="app-arch/rpm2targz
+ dev-util/byacc"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ ebegin "Unpacking lkcd distribution..."
+ # This is the same as using rpm2targz then extracting 'cept that
+ # it's faster, less work, and less hard disk space. rpmoffset is
+ # provided by the rpm2targz package.
+ i="${DISTDIR}/${PN}-4.1-1.src.rpm"
+ dd ibs=`rpmoffset < ${i}` skip=1 if=$i 2>/dev/null \
+ | gzip -dc | cpio -idmu 2>/dev/null && tar xzf ${PN}-4.1-1.tar.gz
+ eend ${?}
+ assert "Failed to extract lkcd distribution..."
+
+ unpack lkcdutils-4.1-savedump.tar.gz
+ unpack lkcdutils-4.1-dhv8.tar.gz
+ cd "${S}"
+ epatch ../lkcdutils-4.1-savedump.diff
+ epatch ../lkcdutils-4.1-dhv8.diff
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --bfd_version=2.14.90 || die "configure failed"
+
+ make || die "make failed"
+}
+
+src_install() {
+ make install ROOT="${D}" || die "install failed"
+ # not needed on s390
+ rm -rf "${D}"/usr/share/sial \
+ "${D}"/usr/lib/libsial.a \
+ "${D}"/usr/include/sial_api.h \
+ "${D}"/usr/include/lkcd/asm/lc_dis.h \
+ "${D}"/etc \
+ "${D}"/sbin/lkcd* \
+ "${D}"/usr/man/man/lkcd*
+ # broken configure script...
+ mv -f "${D}"/usr/man "${D}"/usr/share/man
+}