summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-09 14:52:40 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-09 14:52:40 +0200
commit1a08904c3b876e440d3c08385d24df27c531d23b (patch)
tree2c5dece639c865e8d53353c9cccd3df2ace1055a /sys-apps/mawk/mawk-1.3.4_p20200120.ebuild
parentdev-util/dialog: add changelog (diff)
downloadgentoo-1a08904c3b876e440d3c08385d24df27c531d23b.tar.gz
gentoo-1a08904c3b876e440d3c08385d24df27c531d23b.tar.bz2
gentoo-1a08904c3b876e440d3c08385d24df27c531d23b.zip
sys-apps/mawk: add 1.3.4_p20200120
Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-apps/mawk/mawk-1.3.4_p20200120.ebuild')
-rw-r--r--sys-apps/mawk/mawk-1.3.4_p20200120.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/mawk/mawk-1.3.4_p20200120.ebuild b/sys-apps/mawk/mawk-1.3.4_p20200120.ebuild
new file mode 100644
index 000000000000..d5c01b2a942a
--- /dev/null
+++ b/sys-apps/mawk/mawk-1.3.4_p20200120.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P="${P/_p/-}"
+DESCRIPTION="An (often faster than gawk) awk-interpreter"
+HOMEPAGE="https://invisible-island.net/mawk/mawk.html"
+SRC_URI="https://invisible-mirror.net/archives/${PN}/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="app-eselect/eselect-awk"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( ACKNOWLEDGMENT CHANGES README )
+
+src_configure() {
+ tc-export BUILD_CC
+ econf
+}
+
+src_install() {
+ default
+
+ exeinto /usr/share/doc/${PF}/examples
+ doexe examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+}
+
+pkg_postinst() {
+ eselect awk update ifunset
+}
+
+pkg_postrm() {
+ eselect awk update ifunset
+}