summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-03-18 00:13:16 +0000
committerJason Zaman <perfinion@gentoo.org>2021-04-02 21:15:32 -0700
commit9af7ccc62e3bbbf7f40f4a7ec7e9a7eef7cc793d (patch)
tree3780c6fbe486061b525e49eb4fea3f8f462550f5 /sys-apps/mcstrans/mcstrans-3.2.ebuild
parentsys-apps/secilc: Sync live ebuild. (diff)
downloadgentoo-9af7ccc62e3bbbf7f40f4a7ec7e9a7eef7cc793d.tar.gz
gentoo-9af7ccc62e3bbbf7f40f4a7ec7e9a7eef7cc793d.tar.bz2
gentoo-9af7ccc62e3bbbf7f40f4a7ec7e9a7eef7cc793d.zip
sys-apps/mcstrans: Version updated to 3.2.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps/mcstrans/mcstrans-3.2.ebuild')
-rw-r--r--sys-apps/mcstrans/mcstrans-3.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/mcstrans/mcstrans-3.2.ebuild b/sys-apps/mcstrans/mcstrans-3.2.ebuild
new file mode 100644
index 000000000000..631d654a0a38
--- /dev/null
+++ b/sys-apps/mcstrans/mcstrans-3.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+fi
+
+DESCRIPTION="SELinux context translation to human readable names"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${PV}:=
+ >=sys-libs/libselinux-${PV}:=
+ dev-libs/libpcre:=
+ >=sys-libs/libcap-1.10-r10:="
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ rm -rf "${D}/etc/rc.d" || die
+
+ newinitd "${FILESDIR}/mcstransd.init" mcstransd
+}