summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-07-30 12:02:01 -0500
committerBen Kohler <bkohler@gentoo.org>2021-07-30 12:02:01 -0500
commit6a9bfeda542ecddea41c1eb848118cc14f0dbb9f (patch)
tree826c7ad4b1fc43f4f05ac828a3ac5e2be4478d53 /sys-apps/memtest86-bin
parentapp-admin/xkcdpass: default enable l10n_en (diff)
downloadgentoo-6a9bfeda542ecddea41c1eb848118cc14f0dbb9f.tar.gz
gentoo-6a9bfeda542ecddea41c1eb848118cc14f0dbb9f.tar.bz2
gentoo-6a9bfeda542ecddea41c1eb848118cc14f0dbb9f.zip
sys-apps/memtest86-bin: bump to 9.2
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'sys-apps/memtest86-bin')
-rw-r--r--sys-apps/memtest86-bin/Manifest1
-rw-r--r--sys-apps/memtest86-bin/memtest86-bin-9.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/memtest86-bin/Manifest b/sys-apps/memtest86-bin/Manifest
index 289a9605431e..dc451d36f873 100644
--- a/sys-apps/memtest86-bin/Manifest
+++ b/sys-apps/memtest86-bin/Manifest
@@ -1 +1,2 @@
DIST memtest86-bin-9.1.zip 8561760 BLAKE2B 89d72804d8d38b103f64a576b66fbc654ea81acdd04001922d4f6487ba0b0cde50d18a4446cedfdc540cc7c2315e5a1bca97f6c2c2691aea6b5fdd22df3402a5 SHA512 06fc070fc50d115e57309407569274fa4785383f377cb4e4246195f4af30fce531fcf1b866f3ce0a0a7c174902150c327e6f5158a4c59d708ca0ceeae12179d3
+DIST memtest86-bin-9.2.zip 8640127 BLAKE2B 99a51857f3625705a257edd19722ad662e03599722b9441c101886a22fa185fb284ee23d55a7e261fd442780e966350e291c9b0b39a08115c0c15a45ac3b4c22 SHA512 46e900376e9074162c71259d88b560c2d4a32f900750af3e5b301bea0e15c612788297fbd068939760551173fb4cfb11edff25586dd9bd1f69a6140c1b93da7f
diff --git a/sys-apps/memtest86-bin/memtest86-bin-9.2.ebuild b/sys-apps/memtest86-bin/memtest86-bin-9.2.ebuild
new file mode 100644
index 000000000000..97f87cab2411
--- /dev/null
+++ b/sys-apps/memtest86-bin/memtest86-bin-9.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mount-boot
+
+DESCRIPTION="Stand alone memory testing software for x86 computers"
+HOMEPAGE="http://www.memtest86.com/"
+SRC_URI="https://www.memtest86.com/downloads/memtest86-usb.zip -> ${P}.zip"
+
+LICENSE="PassMark-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+
+BDEPEND="app-arch/unzip
+ sys-fs/fatcat"
+
+S=${WORKDIR}
+
+src_unpack() {
+ default
+ fatcat memtest86-usb.img -O 1048576 -r /EFI/BOOT/BOOTX64.efi > ${PN}.efi || die
+}
+
+src_install() {
+ insinto /boot
+ doins ${PN}.efi
+
+ exeinto /etc/grub.d/
+ newexe "${FILESDIR}"/${PN}-grub.d 39_memtest86-bin
+
+ dodoc MemTest86_User_Guide_UEFI.pdf
+}