summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-21 23:19:19 +0000
committerSam James <sam@gentoo.org>2022-12-21 23:19:38 +0000
commitbc91792833e5c385af3ecf00308a38bd312610fa (patch)
treebd0a9ba84cc5d4537a3d500a42e6da810543e43a /sys-apps/memtester/memtester-4.6.0.ebuild
parentsys-apps/memtester: add changelog upstream metadata (diff)
downloadgentoo-bc91792833e5c385af3ecf00308a38bd312610fa.tar.gz
gentoo-bc91792833e5c385af3ecf00308a38bd312610fa.tar.bz2
gentoo-bc91792833e5c385af3ecf00308a38bd312610fa.zip
sys-apps/memtester: add 4.6.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/memtester/memtester-4.6.0.ebuild')
-rw-r--r--sys-apps/memtester/memtester-4.6.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-apps/memtester/memtester-4.6.0.ebuild b/sys-apps/memtester/memtester-4.6.0.ebuild
new file mode 100644
index 000000000000..52c171c1b2ec
--- /dev/null
+++ b/sys-apps/memtester/memtester-4.6.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Userspace utility for testing the memory subsystem for faults"
+HOMEPAGE="http://pyropus.ca/software/memtester/"
+SRC_URI="
+ https://pyropus.ca./software/memtester/${P}.tar.gz
+ https://pyropus.ca./software/memtester/old-versions/${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+src_configure() {
+ echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS} -DPOSIX -c" > conf-cc || die
+ echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS}" > conf-ld || die
+}
+
+src_install() {
+ dosbin memtester
+ doman memtester.8
+ dodoc BUGS CHANGELOG README README.tests
+}