summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-03-21 22:26:37 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-03-21 22:28:14 +0300
commitbff33c51712c70e9ba0a44c6137219d5b6a8bcb8 (patch)
tree7d0bb0348bb82790efcf726e699b5f02cfa9bee5 /sys-apps/modutils/modutils-2.4.27-r2.ebuild
parentmedia-gfx/imagemagick: Make repoman happy (diff)
downloadgentoo-bff33c51712c70e9ba0a44c6137219d5b6a8bcb8.tar.gz
gentoo-bff33c51712c70e9ba0a44c6137219d5b6a8bcb8.tar.bz2
gentoo-bff33c51712c70e9ba0a44c6137219d5b6a8bcb8.zip
sys-apps/modutils: port to EAPI=7
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-apps/modutils/modutils-2.4.27-r2.ebuild')
-rw-r--r--sys-apps/modutils/modutils-2.4.27-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/modutils/modutils-2.4.27-r2.ebuild b/sys-apps/modutils/modutils-2.4.27-r2.ebuild
new file mode 100644
index 000000000000..a693294a408f
--- /dev/null
+++ b/sys-apps/modutils/modutils-2.4.27-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Standard kernel module utilities for linux-2.4 and older"
+HOMEPAGE="https://www.kernel.org/pub/linux/utils/kernel/modutils/"
+SRC_URI="https://www.kernel.org/pub/linux/utils/kernel/${PN}/v2.4/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86"
+
+RDEPEND="!sys-apps/module-init-tools
+ !sys-apps/kmod"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc.patch
+ "${FILESDIR}"/${P}-flex.patch
+ "${FILESDIR}"/${P}-no-nested-function.patch
+)
+
+src_configure() {
+ econf \
+ --prefix=/ \
+ --disable-strip \
+ --enable-insmod-static \
+ --disable-zlib
+}
+
+src_install() {
+ einstall prefix="${D}"
+ rm -r "${ED}"/usr/share/man/man2 || die
+ dodoc CREDITS ChangeLog NEWS README TODO
+}