summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2021-01-06 18:54:43 -0500
committerMike Frysinger <vapier@gentoo.org>2021-01-06 20:54:23 -0500
commitbee4eb97415b905ac1e4f227aa088b16d268458f (patch)
treee9bcc040e08d72bf2be864ab3ea0435059f9e093 /sys-apps/net-tools/net-tools-2.10.ebuild
parentsys-apps/net-tools: refresh live VCS for new release (diff)
downloadgentoo-bee4eb97415b905ac1e4f227aa088b16d268458f.tar.gz
gentoo-bee4eb97415b905ac1e4f227aa088b16d268458f.tar.bz2
gentoo-bee4eb97415b905ac1e4f227aa088b16d268458f.zip
sys-apps/net-tools: version bump to 2.10
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'sys-apps/net-tools/net-tools-2.10.ebuild')
-rw-r--r--sys-apps/net-tools/net-tools-2.10.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/sys-apps/net-tools/net-tools-2.10.ebuild b/sys-apps/net-tools/net-tools-2.10.ebuild
new file mode 100644
index 000000000000..cba5fc193445
--- /dev/null
+++ b/sys-apps/net-tools/net-tools-2.10.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit flag-o-matic toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/net-tools/code"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Standard Linux networking tools"
+HOMEPAGE="http://net-tools.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+arp +hostname ipv6 nis nls plipconfig selinux slattach static"
+REQUIRED_USE="nis? ( hostname )"
+
+RDEPEND="selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ selinux? ( virtual/pkgconfig )
+ app-arch/xz-utils"
+if [[ ${PV} == "9999" ]]; then
+ DEPEND+=" nls? ( sys-devel/gettext )"
+fi
+RDEPEND+="
+ hostname? ( !sys-apps/coreutils[hostname] )
+ !<sys-apps/openrc-0.9.9.3"
+
+set_opt() {
+ local opt=$1 ans
+ shift
+ ans=$("$@" && echo y || echo n)
+ einfo "Setting option ${opt} to ${ans}"
+ sed -i \
+ -e "/^bool.* ${opt} /s:[yn]$:${ans}:" \
+ config.in || die
+}
+
+src_configure() {
+ # Clear out env vars from the user. #599602
+ unset BASEDIR BINDIR SBINDIR
+
+ set_opt I18N use nls
+ set_opt HAVE_AFINET6 use ipv6
+ set_opt HAVE_HWIB has_version '>=sys-kernel/linux-headers-2.6'
+ set_opt HAVE_HWTR has_version '<sys-kernel/linux-headers-3.5'
+ set_opt HAVE_HWSTRIP has_version '<sys-kernel/linux-headers-3.6'
+ set_opt HAVE_SELINUX use selinux
+ set_opt HAVE_ARP_TOOLS use arp
+ set_opt HAVE_HOSTNAME_TOOLS use hostname
+ set_opt HAVE_HOSTNAME_SYMLINKS use nis
+ set_opt HAVE_PLIP_TOOLS use plipconfig
+ set_opt HAVE_SERIAL_TOOLS use slattach
+ if use static ; then
+ append-flags -static
+ append-ldflags -static
+ fi
+ tc-export AR CC
+ yes "" | ./configure.sh config.in || die
+}
+
+src_install() {
+ # We need to use emake by hand to pass ED. #567300
+ emake DESTDIR="${ED}" install
+ dodoc README THANKS TODO
+}