summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-04-15 10:03:07 -0700
committerZac Medico <zmedico@gentoo.org>2016-04-15 10:03:58 -0700
commitb53eebd68b10a8d6f2af21e680f2a0644e6464fe (patch)
tree4ddf7db5abb055ad728623f63c7c2975056135ca /sys-apps/nvme-cli/nvme-cli-0.6.ebuild
parentkde-frameworks/kauth: Fix dependencies (diff)
downloadgentoo-b53eebd68b10a8d6f2af21e680f2a0644e6464fe.tar.gz
gentoo-b53eebd68b10a8d6f2af21e680f2a0644e6464fe.tar.bz2
gentoo-b53eebd68b10a8d6f2af21e680f2a0644e6464fe.zip
sys-apps/nvme-cli: version bump to 0.6
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-apps/nvme-cli/nvme-cli-0.6.ebuild')
-rw-r--r--sys-apps/nvme-cli/nvme-cli-0.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-apps/nvme-cli/nvme-cli-0.6.ebuild b/sys-apps/nvme-cli/nvme-cli-0.6.ebuild
new file mode 100644
index 000000000000..ea0ac8934b50
--- /dev/null
+++ b/sys-apps/nvme-cli/nvme-cli-0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="NVM-Express user space tooling for Linux"
+HOMEPAGE="https://github.com/linux-nvme/nvme-cli"
+SRC_URI="https://github.com/linux-nvme/nvme-cli/archive/v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="sys-libs/libcap"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed 's|-m64 \(-std=gnu99\) -O2 -g \(-pthread -D_GNU_SOURCE -D_REENTRANT -Wall\) -Werror|\1 \2|' \
+ -i Makefile || die
+ sed 's|/usr/local|$(DESTDIR)/$(PREFIX)/share|' \
+ -i Documentation/Makefile || die
+
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+}