summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-10-31 10:50:21 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-10-31 10:50:28 -0700
commit326b97370a9222e59502b3bbb1f59507bac6fb39 (patch)
treeeb7ebde09d52557b9d04059cc96219fdea662568 /sys-apps/nvme-cli/nvme-cli-2.2.ebuild
parentsys-libs/libnvme: add 1.2 (diff)
downloadgentoo-326b97370a9222e59502b3bbb1f59507bac6fb39.tar.gz
gentoo-326b97370a9222e59502b3bbb1f59507bac6fb39.tar.bz2
gentoo-326b97370a9222e59502b3bbb1f59507bac6fb39.zip
sys-apps/nvme-cli: add 2.2
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-apps/nvme-cli/nvme-cli-2.2.ebuild')
-rw-r--r--sys-apps/nvme-cli/nvme-cli-2.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/nvme-cli/nvme-cli-2.2.ebuild b/sys-apps/nvme-cli/nvme-cli-2.2.ebuild
new file mode 100644
index 000000000000..e306a3a8eb3b
--- /dev/null
+++ b/sys-apps/nvme-cli/nvme-cli-2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson systemd udev
+
+DESCRIPTION="NVM-Express user space tooling for Linux"
+HOMEPAGE="https://github.com/linux-nvme/nvme-cli"
+SRC_URI="https://github.com/linux-nvme/nvme-cli/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+RESTRICT="test"
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="hugepages +json"
+
+RDEPEND="
+ >=sys-libs/libnvme-1.2:=[json=]
+ hugepages? ( sys-libs/libhugetlbfs:= )
+ json? ( dev-libs/json-c:= )
+ sys-libs/zlib:=
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/nvme-cli-2.2-docdir.patch"
+)
+
+src_configure() {
+ local unitdir="$(systemd_get_systemunitdir)"
+ local emesonargs=(
+ -Ddocs=all
+ -Dhtmldir="${EPREFIX}/usr/share/doc/${P}/html"
+ -Dsystemddir="${unitdir%/system}"
+ -Dudevrulesdir="${EPREFIX}$(get_udevdir)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+}