summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-11-08 20:46:50 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-11-08 20:46:50 -0800
commitf8131e08ec9dd3cce01b3976de2be04b8926357b (patch)
tree1fc469f4730c9d8ee08eaaba454f07ede7155982 /sys-apps/opal-utils
parentsys-apps/opal-utils: stabilize 6.8 for ppc64 (diff)
downloadgentoo-f8131e08ec9dd3cce01b3976de2be04b8926357b.tar.gz
gentoo-f8131e08ec9dd3cce01b3976de2be04b8926357b.tar.bz2
gentoo-f8131e08ec9dd3cce01b3976de2be04b8926357b.zip
sys-apps/opal-utils: drop 6.7
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-apps/opal-utils')
-rw-r--r--sys-apps/opal-utils/Manifest1
-rw-r--r--sys-apps/opal-utils/opal-utils-6.7.ebuild94
2 files changed, 0 insertions, 95 deletions
diff --git a/sys-apps/opal-utils/Manifest b/sys-apps/opal-utils/Manifest
index 94472e0f1aaa..e789980f23a7 100644
--- a/sys-apps/opal-utils/Manifest
+++ b/sys-apps/opal-utils/Manifest
@@ -1,2 +1 @@
-DIST opal-utils-6.7.tar.gz 5320182 BLAKE2B e2fa86a7d5d96afda8f8266875687fb3c2e61ca2932ea5585921b2e5cffe30cb3554d85d078448cda032cbc0438d188ea40b5aad6e7f4c923e77fa4e42e6f364 SHA512 1626d64554c608cd823dc27b58f35206cf6d011afde124746e06fd5f1e8c714c199d9f2b60417415daf01cfbc46208d08d49eef29538a515b539a551b8c5e5c3
DIST opal-utils-6.8.tar.gz 5321377 BLAKE2B 3be812618dcbd3d877576e1dec0b6a74ad9091b59760bd8f1f67ba9a8efbce79cba4130464dcb6f2b8e61dedca3a1a60103f36d04fcd234b5a4c577c6e07635b SHA512 a799112c14abdcdb37e1a4c63e48e12bb7a67b6c90476d4e60597f06fd6050a58ffd25859cf6bb12c393522e4b4771ce3aa25a1277bac35855d599e9eb357814
diff --git a/sys-apps/opal-utils/opal-utils-6.7.ebuild b/sys-apps/opal-utils/opal-utils-6.7.ebuild
deleted file mode 100644
index fdaa7271922d..000000000000
--- a/sys-apps/opal-utils/opal-utils-6.7.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit linux-info python-any-r1 systemd toolchain-funcs
-
-DESCRIPTION="OPAL firmware utilities"
-HOMEPAGE="https://github.com/open-power/skiboot"
-SRC_URI="https://github.com/open-power/skiboot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2+"
-SLOT="0"
-KEYWORDS="ppc64"
-IUSE="doc"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-BDEPEND="doc? (
- $(python_gen_any_dep '
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/recommonmark[${PYTHON_USEDEP}]
- ')
-)"
-
-CONFIG_CHECK="~MTD_POWERNV_FLASH ~OPAL_PRD ~PPC_DT_CPU_FTRS ~SCOM_DEBUGFS"
-ERROR_MTD_POWERND_FLASH="CONFIG_MTD_POWERND_FLASH is required to use pflash and opal-gard"
-ERROR_OPAL_PRD="CONFIG_OPAL_PRD is required to run opal-prd daemon"
-ERROR_SCOM_DEBUGFS="CONFIG_SCOM_DEBUGFS is required to use xscom-utils"
-
-S="${WORKDIR}/skiboot-${PV}"
-
-PATCHES=(
- "${FILESDIR}/flags.patch"
-)
-
-python_check_deps() {
- has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" &&
- has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- linux-info_pkg_setup
- use doc && python-any-r1_pkg_setup
-}
-
-src_configure() {
- tc-export CC LD
- export OPAL_PRD_VERSION="${PV}"
- export GARD_VERSION="${PV}"
- export PFLASH_VERSION="${PV}"
- export XSCOM_VERSION="${PV}"
- export FFSPART_VERSION="${PV}"
-}
-
-src_compile() {
- emake V=1 -C external/opal-prd
- emake V=1 -C external/gard
- emake V=1 -C external/pflash
- emake V=1 -C external/xscom-utils
- emake V=1 -C external/ffspart
-
- use doc && emake V=1 -C doc html
-}
-
-src_install() {
- emake -C external/opal-prd DESTDIR="${D}" prefix="${EPREFIX}/usr" install
- emake -C external/gard DESTDIR="${D}" prefix="${EPREFIX}/usr" install
- emake -C external/pflash DESTDIR="${D}" prefix="${EPREFIX}/usr" install
- emake -C external/xscom-utils DESTDIR="${D}" prefix="${EPREFIX}/usr" install
- dosbin external/ffspart/ffspart
-
- newinitd "${FILESDIR}"/opal-prd.initd opal-prd
- newconfd "${FILESDIR}"/opal-prd.confd opal-prd
-
- systemd_dounit external/opal-prd/opal-prd.service
-
- if use doc; then
- rm -r doc/_build/html/_sources || die
- local HTML_DOCS=( doc/_build/html/. )
- fi
- einstalldocs
-}
-
-src_test() {
- emake V=1 -C external/opal-prd test
- emake V=1 -C external/gard check
- # this test is fragile and fails because of filename path
- rm external/pflash/test/tests/01-info || die
- emake V=1 -C external/pflash check
- emake V=1 -C external/ffspart check
-}