summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/pacman/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/pacman/files')
-rw-r--r--sys-apps/pacman/files/pacman-4.0.0-gpgme.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/pacman/files/pacman-4.0.0-gpgme.patch b/sys-apps/pacman/files/pacman-4.0.0-gpgme.patch
new file mode 100644
index 000000000000..ab0f57c7a162
--- /dev/null
+++ b/sys-apps/pacman/files/pacman-4.0.0-gpgme.patch
@@ -0,0 +1,45 @@
+From fc732def0944aac5c7b18860b4f46444e6d50044 Mon Sep 17 00:00:00 2001
+From: Nathan Phillip Brink <binki@gentoo.org>
+Date: Mon, 17 Oct 2011 21:01:22 +0000
+Subject: [PATCH] Use AM_GPGME_PATH macro from gpgme instead of home-built gpgme detection.
+
+Fixes compilation on Gentoo, where CPPFLAGS=-I/usr/include/gpgme is
+necessary.
+---
+ configure.ac | 20 ++++++++++++--------
+ 1 files changed, 12 insertions(+), 8 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index c23da75..87cd359 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -161,14 +161,18 @@ AM_CONDITIONAL([HAVE_LIBSSL], [test "x$with_openssl" = "xyes"])
+ # Check for gpgme
+ AC_MSG_CHECKING(whether to link with libgpgme)
+ AS_IF([test "x$with_gpgme" != "xno"],
+- [AC_MSG_RESULT(yes)
+- AC_CHECK_LIB([gpgme], [gpgme_check_version], ,
+- [if test "x$with_gpgme" != "xcheck"; then
+- AC_MSG_FAILURE([--with-ggpme was given, but -lgpgme was not found])
+- fi],
+- [-lgpgme])
+- with_gpgme=$ac_cv_lib_gpgme_gpgme_check_version],
+- AC_MSG_RESULT(no))
++ [AC_MSG_RESULT([yes])],
++ [AC_MSG_RESULT([no])])
++AS_IF([test "x$with_gpgme" != "xno"],
++ [AM_PATH_GPGME([],
++ [LIBS="$LIBS $GPGME_LIBS"
++ CPPFLAGS="$CPPFLAGS $GPGME_CPPFLAGS"
++ CFLAGS="$CFLAGS $GPGME_CFLAGS"
++ with_gpgme=yes
++ AC_DEFINE([HAVE_LIBGPGME], [1], [Define if gpgme should be used to provide GPG signature support.])],
++ [AS_IF([test "x$with_gpgme" != "xcheck"],
++ [AC_MSG_FAILURE([--with-gpgme was given, but gpgme was not found])])
++ with_gpgme=no])])
+ AM_CONDITIONAL([HAVE_LIBGPGME], [test "x$with_gpgme" = "xyes"])
+
+ # Checks for header files.
+--
+1.7.3.4
+