summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-24 22:26:02 +0100
committerSam James <sam@gentoo.org>2022-05-24 22:26:02 +0100
commit7f296ba04cc9c825875b4d9fe5df8dbfd2971cd9 (patch)
tree3e4e825a4adbf047f90274f278c58846f6000a5d /sys-apps/pciutils
parentsys-apps/pciutils: add regex for LD version to be safe (diff)
downloadgentoo-7f296ba04cc9c825875b4d9fe5df8dbfd2971cd9.tar.gz
gentoo-7f296ba04cc9c825875b4d9fe5df8dbfd2971cd9.tar.bz2
gentoo-7f296ba04cc9c825875b4d9fe5df8dbfd2971cd9.zip
sys-apps/pciutils: mention why 2.37 check
It's to prevent catastrophies from people running with an older Binutils in general, even if 2.35 is strictly enough (probably, not tried myself) to build this package, given older binutils can cause all sorts of problems, it should be considered a wake-up call for people running such an old one, rather than just encouraging them to bump to the lowest possible version which will work (< 2.37 is masked in Gentoo and has been for a while, and we're not backporting any fixes for it.) Bug: https://bugs.gentoo.org/802036 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/pciutils')
-rw-r--r--sys-apps/pciutils/pciutils-3.8.0.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-apps/pciutils/pciutils-3.8.0.ebuild b/sys-apps/pciutils/pciutils-3.8.0.ebuild
index e92c695e88d3..53e69aa143eb 100644
--- a/sys-apps/pciutils/pciutils-3.8.0.ebuild
+++ b/sys-apps/pciutils/pciutils-3.8.0.ebuild
@@ -68,6 +68,11 @@ check_binutils_version() {
ver_major=$(ver_cut 1 "${ver}")
ver_minor=$(ver_cut 2 "${ver}")
+ # We use 2.37 here, not 2.35, as https://github.com/pciutils/pciutils/issues/98 mentions
+ # because we've had other miscompiles with older Binutils (not just build failures!)
+ # and we don't want people running any unsupported versions of Binutils. An example
+ # of this is where glibc is completely broken with old binutils: bug #802036. It's
+ # just not sustainable to support.
if [[ ${ver_major} -eq 2 && ${ver_minor} -lt 37 ]] ; then
eerror "Old version of binutils activated! ${P} cannot be built with an old version."
eerror "Please follow these steps:"