summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2015-08-11 23:08:09 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2015-08-11 23:09:01 +0300
commitd03982c0deae40cfd9dd476329dae33a44b22c8d (patch)
tree0ea5b979e0fbdeedd570f1054bbda767556c8dc7 /sys-apps/pcsc-tools/pcsc-tools-1.4.24.ebuild
parentsys-apps/pcsc-lite: version bump (diff)
downloadgentoo-d03982c0deae40cfd9dd476329dae33a44b22c8d.tar.gz
gentoo-d03982c0deae40cfd9dd476329dae33a44b22c8d.tar.bz2
gentoo-d03982c0deae40cfd9dd476329dae33a44b22c8d.zip
sys-apps/pcsc-tools: version bump
Bug: 557258 Package-Manager: portage-2.2.20
Diffstat (limited to 'sys-apps/pcsc-tools/pcsc-tools-1.4.24.ebuild')
-rw-r--r--sys-apps/pcsc-tools/pcsc-tools-1.4.24.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.4.24.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.4.24.ebuild
new file mode 100644
index 000000000000..0751451a76e4
--- /dev/null
+++ b/sys-apps/pcsc-tools/pcsc-tools-1.4.24.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit eutils fdo-mime multilib toolchain-funcs
+
+DESCRIPTION="PC/SC Architecture smartcard tools"
+HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/"
+SRC_URI="http://ludovic.rousseau.free.fr/softwares/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="gtk network-cron"
+
+RDEPEND=">=sys-apps/pcsc-lite-1.4.14"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ dev-perl/pcsc-perl
+ gtk? ( dev-perl/gtk2-perl )"
+
+src_prepare() {
+ sed -i -e 's:-Wall -O2:$(CFLAGS):g' Makefile
+}
+
+src_compile() {
+ # explicitly only build the pcsc_scan application, or the man
+ # pages will be gzipped first, and then unpacked.
+ emake pcsc_scan CC=$(tc-getCC)
+}
+
+src_install() {
+ # install manually, makes it much easier since the Makefile
+ # requires fiddling with
+ dobin ATR_analysis scriptor pcsc_scan
+ doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
+
+ dodoc README Changelog
+
+ if use gtk; then
+ domenu gscriptor.desktop
+ dobin gscriptor
+ doman gscriptor.1p
+ fi
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
+ fi
+
+ insinto /usr/share/pcsc
+ doins smartcard_list.txt
+}
+
+pkg_postinst() {
+ use gtk && fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}