summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/pcsc-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/pcsc-tools')
-rw-r--r--sys-apps/pcsc-tools/Manifest2
-rw-r--r--sys-apps/pcsc-tools/files/smartcard.cron15
-rw-r--r--sys-apps/pcsc-tools/metadata.xml10
-rw-r--r--sys-apps/pcsc-tools/pcsc-tools-1.4.22.ebuild65
-rw-r--r--sys-apps/pcsc-tools/pcsc-tools-1.4.23.ebuild65
5 files changed, 157 insertions, 0 deletions
diff --git a/sys-apps/pcsc-tools/Manifest b/sys-apps/pcsc-tools/Manifest
new file mode 100644
index 000000000000..6ab630b9e70c
--- /dev/null
+++ b/sys-apps/pcsc-tools/Manifest
@@ -0,0 +1,2 @@
+DIST pcsc-tools-1.4.22.tar.gz 109458 SHA256 615592dd56627bd0ff3650608bb7eefe3e9f43cc18ca2d805ebf0bf74d30f307 SHA512 cb4bea7bd75e98fda5ff44e3fd680a479cddb3edd6c632951346d2a87329386b55203dc3f2f29d484c23ee4c6cb8f741aaa6b94dd16095b86c7f88f057015cf5 WHIRLPOOL 2f4141034f013970bd43050c70d24e9ab7ee076a29d86d939cc0dc250b4431b6515f04a3e21f179e015c6d80312a70e07101732085e84bf48f5645e7de306c08
+DIST pcsc-tools-1.4.23.tar.gz 114495 SHA256 69ca7bb6ee23ef99e2696451f2f56072dd74adcc43272d89fd757ac8f7de4fe2 SHA512 b94fd467ded600f6ad47510225d325635a227f2bbbe8dbb191fee31a3ccaff951d0ea4a7184765912f00dbf4725b5fcbc478b769fc0dd4369eab0a8c1d627f93 WHIRLPOOL 7ca4c25af05d4f8bebe5a73a3d4e9409d882c42816a25139d218c85ff2464382637ea2049bf176b73ba65a7d483075f23c2087b4a28bf9b38c0102538ca07467
diff --git a/sys-apps/pcsc-tools/files/smartcard.cron b/sys-apps/pcsc-tools/files/smartcard.cron
new file mode 100644
index 000000000000..314f46f107ef
--- /dev/null
+++ b/sys-apps/pcsc-tools/files/smartcard.cron
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+set -e
+
+SRC=http://ludovic.rousseau.free.fr/softwares/pcsc-tools/smartcard_list.txt
+DEST=/usr/share/pcsc/smartcard_list.txt
+
+touch ${DEST} >/dev/null 2>&1 || exit 1
+
+if ! wget --quiet --no-timestamping -O "${DEST}".new "$SRC"; then
+ rm -f "${DEST}".new
+fi
+
+chmod a+r "${DEST}".new
+mv "${DEST}".new "${DEST}"
diff --git a/sys-apps/pcsc-tools/metadata.xml b/sys-apps/pcsc-tools/metadata.xml
new file mode 100644
index 000000000000..c6a053218727
--- /dev/null
+++ b/sys-apps/pcsc-tools/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>crypto</herd>
+ <longdescription>User tools for PC/SC SmartCard access (including pcsc_scan and the gscriptor GUI).</longdescription>
+
+ <use>
+ <flag name='network-cron'>Monthly cronjob the update-smartcard_list script</flag>
+ </use>
+</pkgmetadata>
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.4.22.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.4.22.ebuild
new file mode 100644
index 000000000000..f00141faee11
--- /dev/null
+++ b/sys-apps/pcsc-tools/pcsc-tools-1.4.22.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils fdo-mime multilib toolchain-funcs
+
+DESCRIPTION="PC/SC Architecture smartcard tools"
+HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/"
+SRC_URI="http://ludovic.rousseau.free.fr/softwares/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="gtk network-cron"
+
+RDEPEND=">=sys-apps/pcsc-lite-1.4.14"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ dev-perl/pcsc-perl
+ gtk? ( dev-perl/gtk2-perl )"
+
+src_prepare() {
+ sed -i -e 's:-Wall -O2:$(CFLAGS):g' Makefile
+}
+
+src_compile() {
+ # explicitly only build the pcsc_scan application, or the man
+ # pages will be gzipped first, and then unpacked.
+ emake pcsc_scan CC=$(tc-getCC)
+}
+
+src_install() {
+ # install manually, makes it much easier since the Makefile
+ # requires fiddling with
+ dobin ATR_analysis scriptor pcsc_scan
+ doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
+
+ dodoc README Changelog
+
+ if use gtk; then
+ domenu gscriptor.desktop
+ dobin gscriptor
+ doman gscriptor.1p
+ fi
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
+ fi
+
+ insinto /usr/share/pcsc
+ doins smartcard_list.txt
+}
+
+pkg_postinst() {
+ use gtk && fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.4.23.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.4.23.ebuild
new file mode 100644
index 000000000000..f00141faee11
--- /dev/null
+++ b/sys-apps/pcsc-tools/pcsc-tools-1.4.23.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils fdo-mime multilib toolchain-funcs
+
+DESCRIPTION="PC/SC Architecture smartcard tools"
+HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/"
+SRC_URI="http://ludovic.rousseau.free.fr/softwares/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="gtk network-cron"
+
+RDEPEND=">=sys-apps/pcsc-lite-1.4.14"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ dev-perl/pcsc-perl
+ gtk? ( dev-perl/gtk2-perl )"
+
+src_prepare() {
+ sed -i -e 's:-Wall -O2:$(CFLAGS):g' Makefile
+}
+
+src_compile() {
+ # explicitly only build the pcsc_scan application, or the man
+ # pages will be gzipped first, and then unpacked.
+ emake pcsc_scan CC=$(tc-getCC)
+}
+
+src_install() {
+ # install manually, makes it much easier since the Makefile
+ # requires fiddling with
+ dobin ATR_analysis scriptor pcsc_scan
+ doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
+
+ dodoc README Changelog
+
+ if use gtk; then
+ domenu gscriptor.desktop
+ dobin gscriptor
+ doman gscriptor.1p
+ fi
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
+ fi
+
+ insinto /usr/share/pcsc
+ doins smartcard_list.txt
+}
+
+pkg_postinst() {
+ use gtk && fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}