summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@aarsen.me>2021-08-19 02:40:45 +0200
committerSam James <sam@gentoo.org>2021-08-19 03:15:13 +0100
commitf86f7acf1b4cb919a762e1595dea1011463099c7 (patch)
treeb883145aff7609d02138ebbe1a1b0b314cb24993 /sys-apps/plocate
parentmail-mta/netqmail: put virtuals in PDEPEND (diff)
downloadgentoo-f86f7acf1b4cb919a762e1595dea1011463099c7.tar.gz
gentoo-f86f7acf1b4cb919a762e1595dea1011463099c7.tar.bz2
gentoo-f86f7acf1b4cb919a762e1595dea1011463099c7.zip
sys-apps/plocate: add version 1.1.9
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Arsen Arsenović <arsen@aarsen.me> Closes: https://github.com/gentoo/gentoo/pull/22022 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/plocate')
-rw-r--r--sys-apps/plocate/Manifest1
-rw-r--r--sys-apps/plocate/files/plocate-1.1.9-no-systemd-check.patch38
-rw-r--r--sys-apps/plocate/plocate-1.1.9.ebuild82
3 files changed, 121 insertions, 0 deletions
diff --git a/sys-apps/plocate/Manifest b/sys-apps/plocate/Manifest
index 4d4a1d480d44..381cb363f745 100644
--- a/sys-apps/plocate/Manifest
+++ b/sys-apps/plocate/Manifest
@@ -1 +1,2 @@
DIST plocate-1.1.8.tar.gz 71569 BLAKE2B 06ad0e9535b76bf0102cdeeb6014e2d84f85f51f5926520566e9c6871f04ac09651bb0674ed679d2a4c0d4e516e55dfef35a7021112fad3549bf76993554aeb5 SHA512 a685347df64ac1a3eb7789cb7023b4d0ffed5fb7435a4bd88c3943991e145a387829532ec0c01d30d851b97b8d3173ff4c7c274775e639b75f0b1b45e5bca2a6
+DIST plocate-1.1.9.tar.gz 71973 BLAKE2B c761735ee54c6f8430839dee1582b10e7eaf15e29cefed94d59221d0111d002cac88d86050099b6cdf0130b71a995c0d26fe57cbd9eccdf00b3489f5bd1ae432 SHA512 2a2bffa338add760e598ac14b68d063cb0cc7df244b6af84f70166294a0c0b66acdedce432d0573e8f2d8dcd3ddba597baa407e93cddc5c58a0b492a1e031135
diff --git a/sys-apps/plocate/files/plocate-1.1.9-no-systemd-check.patch b/sys-apps/plocate/files/plocate-1.1.9-no-systemd-check.patch
new file mode 100644
index 000000000000..677f20fc7995
--- /dev/null
+++ b/sys-apps/plocate/files/plocate-1.1.9-no-systemd-check.patch
@@ -0,0 +1,38 @@
+From 0b1e568bc66df9fdb0bfd6f54b4ff2e540769dbe Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Arsen=20Arsenovi=C4=87?= <arsen@aarsen.me>
+Date: Thu, 19 Aug 2021 02:36:54 +0200
+Subject: [PATCH] unconditionally configure systemd service
+
+---
+ meson.build | 15 +++------------
+ 1 file changed, 3 insertions(+), 12 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index dc14eb1..9a3b3fe 100644
+--- a/meson.build
++++ b/meson.build
+@@ -76,18 +76,9 @@ updatedb_conf_man = configure_file(input: 'updatedb.conf.5.in',
+ configuration: conf_data)
+ install_man(updatedb_conf_man)
+
+-if get_option('install_systemd')
+- unitdir = get_option('systemunitdir')
+- if unitdir == ''
+- unitdir = dependency('systemd').get_pkgconfig_variable('systemdsystemunitdir')
+- endif
+-
+- updatedb_service = configure_file(input: 'plocate-updatedb.service.in',
+- output: 'plocate-updatedb.service',
+- configuration: conf_data)
+- install_data(updatedb_service, install_dir: unitdir)
+- install_data('plocate-updatedb.timer', install_dir: unitdir)
+-endif
++updatedb_service = configure_file(input: 'plocate-updatedb.service.in',
++ output: 'plocate-updatedb.service',
++ configuration: conf_data)
+
+ # Requires having TurboPFor checked out, so not built by default.
+ # Unless you have a recent Meson, there's no apparently good way
+--
+2.31.1
+
diff --git a/sys-apps/plocate/plocate-1.1.9.ebuild b/sys-apps/plocate/plocate-1.1.9.ebuild
new file mode 100644
index 000000000000..8153e282f373
--- /dev/null
+++ b/sys-apps/plocate/plocate-1.1.9.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info meson systemd
+
+DESCRIPTION="Posting locate is a much faster locate"
+HOMEPAGE="https://plocate.sesse.net/"
+SRC_URI="https://plocate.sesse.net/download/${P}.tar.gz"
+
+# GPL-2 for updatedb
+# GPL-2+ for plocate itself
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="+io-uring"
+
+RDEPEND="
+ acct-group/locate
+ app-arch/zstd:=
+ io-uring? ( sys-libs/liburing:= )
+ !sys-apps/mlocate
+"
+DEPEND="${RDEPEND}"
+
+CONFIG_CHECK="~IO_URING"
+ERROR_IO_URING="required for USE=io-uring"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.9-no-systemd-check.patch
+)
+
+src_prepare() {
+ # Pretend liburing dep doesn't exist when USE flag off
+ if ! use io-uring; then
+ sed -i "s/dependency('liburing/dependency('/" meson.build || die
+ fi
+
+ # We'll install the manpage ourself to locate.1
+ sed -i "/install_man('plocate.1')/d" meson.build || die
+
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dlocategroup=locate
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dodoc README NEWS
+ newman "${S}"/${PN}.1 locate.1
+ dosym plocate /usr/bin/locate
+
+ insinto /etc
+ doins "${FILESDIR}"/updatedb.conf
+ doins "${FILESDIR}"/plocate-cron.conf
+ fperms 0644 /etc/{updatedb,plocate-cron}.conf
+
+ insinto /etc/cron.daily
+ # Ensure that the cron file has the same name as the
+ # systemd-timer, to avoid plocate being run twice daily on systems
+ # with a systemd compatiblity layer. See also bug #780351.
+ newins "${FILESDIR}"/plocate.cron plocate-updatedb
+ fperms 0755 /etc/cron.daily/plocate-updatedb
+
+ systemd_dounit "${BUILD_DIR}"/${PN}-updatedb.service "${S}"/${PN}-updatedb.timer
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]] ; then
+ elog "The database for the locate command is generated daily by a cron job,"
+ elog "if you install for the first time you can run the updatedb command manually now."
+ elog
+ elog "Note that the ${EROOT}/etc/updatedb.conf file is generic,"
+ elog "please customize it to your system requirements."
+ fi
+}