summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2017-01-15 10:50:43 +0100
committerSven Vermeulen <swift@gentoo.org>2017-01-15 10:51:23 +0100
commitd80c3ce2312f3855b1b32f239c2bd12775ce0d1b (patch)
treebd89728b50b94c113cd62b21d90ec1e6f7d57339 /sys-apps/policycoreutils/policycoreutils-9999.ebuild
parentnet-mail/yosucker: remove unused patch (diff)
downloadgentoo-d80c3ce2312f3855b1b32f239c2bd12775ce0d1b.tar.gz
gentoo-d80c3ce2312f3855b1b32f239c2bd12775ce0d1b.tar.bz2
gentoo-d80c3ce2312f3855b1b32f239c2bd12775ce0d1b.zip
sys-apps/policycoreutils: Depend on audit[python], fix selocal and fix build instructions for 2.6 and higher
The live ebuild reflects the latest state of the user space project of SELinux. In the release of 2.6, a number of changes to the 2.6 ebuild were made but not pushed to the live ebuild, so we did that. Alongside, we also fixed the following bugs: - Bug 605692 fixes the audit dependency - we already depended on audit if USE=audit was set, but we did not force the use of the python USE flag if we did, which is a requirement (note that this bug is partially fixed by this, another change is still pending). - Bug 597978 fixes the selocal command, which failed to obtain attribute and other information since the setools 4 release Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-apps/policycoreutils/policycoreutils-9999.ebuild')
-rw-r--r--sys-apps/policycoreutils/policycoreutils-9999.ebuild23
1 files changed, 16 insertions, 7 deletions
diff --git a/sys-apps/policycoreutils/policycoreutils-9999.ebuild b/sys-apps/policycoreutils/policycoreutils-9999.ebuild
index 37ac23d060fe..085c7fdb5edc 100644
--- a/sys-apps/policycoreutils/policycoreutils-9999.ebuild
+++ b/sys-apps/policycoreutils/policycoreutils-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -11,7 +11,7 @@ inherit multilib python-r1 toolchain-funcs bash-completion-r1
MY_P="${P//_/-}"
MY_RELEASEDATE="20161014"
-EXTRAS_VER="1.34"
+EXTRAS_VER="1.35"
SEMNG_VER="${PV}"
SELNX_VER="${PV}"
SEPOL_VER="${PV}"
@@ -24,13 +24,13 @@ HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
- SRC_URI="https://dev.gentoo.org/~perfinion/distfiles/policycoreutils-extra-${EXTRAS_VER}.tar.bz2"
+ SRC_URI="mirror://gentoo/policycoreutils-extra-${EXTRAS_VER}.tar.bz2"
S1="${WORKDIR}/${MY_P}/${PN}"
S2="${WORKDIR}/policycoreutils-extra"
S="${S1}"
else
SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz
- https://dev.gentoo.org/~perfinion/distfiles/policycoreutils-extra-${EXTRAS_VER}.tar.bz2"
+ mirror://gentoo/policycoreutils-extra-${EXTRAS_VER}.tar.bz2"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
S1="${WORKDIR}/${MY_P}"
S2="${WORKDIR}/policycoreutils-extra"
@@ -53,15 +53,18 @@ DEPEND=">=sys-libs/libselinux-${SELNX_VER}:=[python]
sys-apps/dbus
dev-libs/dbus-glib:=
)
- audit? ( >=sys-process/audit-1.5.1 )
+ audit? ( >=sys-process/audit-1.5.1[python] )
pam? ( sys-libs/pam:= )
- ${PYTHON_DEPS}"
+ ${PYTHON_DEPS}
+ !<sec-policy/selinux-base-policy-2.20151208-r6"
+# 2.20151208-r6 and higher has support for new setfiles
### libcgroup -> seunshare
### dbus -> restorecond
# pax-utils for scanelf used by rlpkg
RDEPEND="${DEPEND}
+ dev-python/sepolgen
app-misc/pax-utils
!<sys-apps/openrc-0.14"
@@ -166,9 +169,15 @@ src_install() {
keepdir /var/lib/selinux
# Set version-specific scripts
- for pyscript in rlpkg; do
+ for pyscript in audit2allow sepolgen-ifgen sepolicy chcat; do
+ python_replicate_script "${ED}/usr/bin/${pyscript}"
+ done
+ for pyscript in semanage rlpkg; do
python_replicate_script "${ED}/usr/sbin/${pyscript}"
done
+
+ dodir /usr/share/doc/${PF}/mcstrans/examples
+ cp -dR "${S1}"/mcstrans/share/examples/* "${D}/usr/share/doc/${PF}/mcstrans/examples" || die
}
pkg_postinst() {