summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-02-01 08:55:44 -0800
committerZac Medico <zmedico@gentoo.org>2017-02-01 11:53:59 -0800
commitdbe0bd44461aff3097fde6c64147f1a61e30816d (patch)
tree5ea5119dee03f4128cabc163f61862295e3a4135 /sys-apps/portage/portage-9999.ebuild
parentdev-libs/libressl: version bumps 2.3.10, 2.4,5, 2.5.1, remove older (diff)
downloadgentoo-dbe0bd44461aff3097fde6c64147f1a61e30816d.tar.gz
gentoo-dbe0bd44461aff3097fde6c64147f1a61e30816d.tar.bz2
gentoo-dbe0bd44461aff3097fde6c64147f1a61e30816d.zip
sys-apps/portage: add native-extensions USE flag (bug 571444)
The native-extensions USE flag will enable building of the libc bindings. This is not enabled by default because it does not support cross compilation. X-Gentoo-bug: 571444 X-Gentoo-bug-url: https://bugs.gentoo.org/show_bug.cgi?id=571444 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-apps/portage/portage-9999.ebuild')
-rw-r--r--sys-apps/portage/portage-9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index 6a6f515f1add..f4f3fec7d67d 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
LICENSE="GPL-2"
KEYWORDS=""
SLOT="0"
-IUSE="build doc epydoc +ipc linguas_ru selinux xattr"
+IUSE="build doc epydoc +ipc linguas_ru native-extensions selinux xattr"
DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
>=app-arch/tar-1.27
@@ -85,6 +85,11 @@ pkg_setup() {
python_prepare_all() {
distutils-r1_python_prepare_all
+ if use native-extensions; then
+ printf "[build_ext]\nportage-ext-modules=true\n" >> \
+ setup.cfg || die
+ fi
+
if ! use ipc ; then
einfo "Disabling ipc..."
sed -e "s:_enable_ipc_daemon = True:_enable_ipc_daemon = False:" \