summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-01-04 15:55:17 -0800
committerZac Medico <zmedico@gentoo.org>2018-01-04 15:56:38 -0800
commit72533ec33e2fa41ac5f9859a4e1826a1baac512a (patch)
tree282e3bafd4d13ec318c20521d32b163d46731d9c /sys-apps/portage
parentapp-shells/bash: Remove redundant code in bashrc, bug #625304 (diff)
downloadgentoo-72533ec33e2fa41ac5f9859a4e1826a1baac512a.tar.gz
gentoo-72533ec33e2fa41ac5f9859a4e1826a1baac512a.tar.bz2
gentoo-72533ec33e2fa41ac5f9859a4e1826a1baac512a.zip
sys-apps/portage: eliminate virtual/tmpfiles dependency
Closes: https://bugs.gentoo.org/643386 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-apps/portage')
-rw-r--r--sys-apps/portage/portage-2.3.19-r1.ebuild7
-rw-r--r--sys-apps/portage/portage-9999.ebuild7
2 files changed, 8 insertions, 6 deletions
diff --git a/sys-apps/portage/portage-2.3.19-r1.ebuild b/sys-apps/portage/portage-2.3.19-r1.ebuild
index 1c78b4a699f7..ad03ed45ed62 100644
--- a/sys-apps/portage/portage-2.3.19-r1.ebuild
+++ b/sys-apps/portage/portage-2.3.19-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -10,7 +10,7 @@ PYTHON_COMPAT=(
)
PYTHON_REQ_USE='bzip2(+),threads(+)'
-inherit distutils-r1 tmpfiles
+inherit distutils-r1
DESCRIPTION="Portage is the package management and distribution system for Gentoo"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
@@ -203,7 +203,8 @@ python_install_all() {
esetup.py "${targets[@]}"
fi
- dotmpfiles "${FILESDIR}"/portage-ccache.conf
+ insinto /usr/lib/tmpfiles.d
+ doins "${FILESDIR}"/portage-ccache.conf
# Due to distutils/python-exec limitations
# these must be installed to /usr/bin.
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index e025371418af..db45902de9a1 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -10,7 +10,7 @@ PYTHON_COMPAT=(
)
PYTHON_REQ_USE='bzip2(+),threads(+)'
-inherit distutils-r1 git-r3 tmpfiles
+inherit distutils-r1 git-r3
DESCRIPTION="Portage is the package management and distribution system for Gentoo"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
@@ -202,7 +202,8 @@ python_install_all() {
esetup.py "${targets[@]}"
fi
- dotmpfiles "${FILESDIR}"/portage-ccache.conf
+ insinto /usr/lib/tmpfiles.d
+ doins "${FILESDIR}"/portage-ccache.conf
# Due to distutils/python-exec limitations
# they must be installed to /usr/bin.