summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/pv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/pv')
-rw-r--r--sys-apps/pv/Manifest1
-rw-r--r--sys-apps/pv/metadata.xml11
-rw-r--r--sys-apps/pv/pv-1.6.0-r1.ebuild52
-rw-r--r--sys-apps/pv/pv-1.6.0.ebuild44
4 files changed, 108 insertions, 0 deletions
diff --git a/sys-apps/pv/Manifest b/sys-apps/pv/Manifest
new file mode 100644
index 000000000000..870c01da6bfe
--- /dev/null
+++ b/sys-apps/pv/Manifest
@@ -0,0 +1 @@
+DIST pv-1.6.0.tar.bz2 107723 SHA256 0ece824e0da27b384d11d1de371f20cafac465e038041adab57fcf4b5036ef8d SHA512 bd405901812ca50b910adbcf1d2c540dc0b8612f03687866734a79cfa5b5b8100024c18a1d1413c6613e1f2085989cbb77907da89bec7eda37cdeaa7597129d5 WHIRLPOOL 51312339fa1815a61f58fa0f49b0538289d0308b17c5d03c4c6a7e371052e9911d09cb7a9c1eb032b797a3f56eaa7e5dbfecaf6fb2c1faf3fd1b34c298782c1f
diff --git a/sys-apps/pv/metadata.xml b/sys-apps/pv/metadata.xml
new file mode 100644
index 000000000000..e021cd5922f5
--- /dev/null
+++ b/sys-apps/pv/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jer@gentoo.org</email>
+ <name>Jeroen Roovers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">pipeviewer</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/pv/pv-1.6.0-r1.ebuild b/sys-apps/pv/pv-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..4afd5f03fe22
--- /dev/null
+++ b/sys-apps/pv/pv-1.6.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="Pipe Viewer: a tool for monitoring the progress of data through a pipe"
+HOMEPAGE="http://www.ivarch.com/programs/pv.shtml"
+SRC_URI="http://www.ivarch.com/programs/sources/${P}.tar.bz2"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris ~x86-solaris"
+IUSE="debug nls"
+
+PV_LINGUAS=( de fr pl pt )
+IUSE+=" ${PV_LINGUAS[@]/#/linguas_}"
+
+DOCS=( README doc/NEWS doc/TODO )
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~SYSVIPC"
+ ERROR_SYSVIPC="You will need to enable CONFIG_SYSVIPC in your kernel to use the --remote option."
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ sed -i configure -e 's|CFLAGS="-g -Wall"|:|g' || die
+ # These should produce the same end result (working `pv`).
+ sed -i \
+ -e 's:$(LD) $(LDFLAGS) -o:$(AR) rc:' \
+ autoconf/make/modules.mk~ || die
+}
+
+src_configure() {
+ tc-export AR
+ local lingua
+ for lingua in ${PV_LINGUAS[@]}; do
+ if ! use linguas_${lingua}; then
+ sed -i configure -e "/ALL_LINGUAS=/s:${lingua}::g" || die
+ fi
+ done
+ econf $(use_enable debug debugging) $(use_enable nls)
+}
+
+src_test() {
+ sed -i -e 's:usleep 200000 || ::g' tests/019-remote-cksum || die
+ default
+}
diff --git a/sys-apps/pv/pv-1.6.0.ebuild b/sys-apps/pv/pv-1.6.0.ebuild
new file mode 100644
index 000000000000..4cbc0b19af47
--- /dev/null
+++ b/sys-apps/pv/pv-1.6.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Pipe Viewer: a tool for monitoring the progress of data through a pipe"
+HOMEPAGE="http://www.ivarch.com/programs/pv.shtml"
+SRC_URI="http://www.ivarch.com/programs/sources/${P}.tar.bz2"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris ~x86-solaris"
+IUSE="debug nls"
+
+PV_LINGUAS=( de fr pl pt )
+IUSE+=" ${PV_LINGUAS[@]/#/linguas_}"
+
+DOCS=( README doc/NEWS doc/TODO )
+
+src_prepare() {
+ sed -i configure -e 's|CFLAGS="-g -Wall"|:|g' || die
+ # These should produce the same end result (working `pv`).
+ sed -i \
+ -e 's:$(LD) $(LDFLAGS) -o:$(AR) rc:' \
+ autoconf/make/modules.mk~ || die
+}
+
+src_configure() {
+ tc-export AR
+ local lingua
+ for lingua in ${PV_LINGUAS[@]}; do
+ if ! use linguas_${lingua}; then
+ sed -i configure -e "/ALL_LINGUAS=/s:${lingua}::g" || die
+ fi
+ done
+ econf $(use_enable debug debugging) $(use_enable nls)
+}
+
+src_test() {
+ sed -i -e 's:usleep 200000 || ::g' tests/019-remote-cksum || die
+ default
+}