summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-03-18 00:18:04 +0000
committerJason Zaman <perfinion@gentoo.org>2021-04-02 21:15:34 -0700
commitb8dfa34696c352eb12868d4eb21a1de716f08c05 (patch)
tree309eb0f3ca78730c3568357e3c2dd2fcd1dedce4 /sys-apps/restorecond/restorecond-3.2.ebuild
parentsys-apps/mcstrans: Sync live ebuild. (diff)
downloadgentoo-b8dfa34696c352eb12868d4eb21a1de716f08c05.tar.gz
gentoo-b8dfa34696c352eb12868d4eb21a1de716f08c05.tar.bz2
gentoo-b8dfa34696c352eb12868d4eb21a1de716f08c05.zip
sys-apps/restorecond: Version updated to 3.2.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps/restorecond/restorecond-3.2.ebuild')
-rw-r--r--sys-apps/restorecond/restorecond-3.2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/restorecond/restorecond-3.2.ebuild b/sys-apps/restorecond/restorecond-3.2.ebuild
new file mode 100644
index 000000000000..f3e66897e8c1
--- /dev/null
+++ b/sys-apps/restorecond/restorecond-3.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit systemd toolchain-funcs
+
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+fi
+
+DESCRIPTION="Daemon to watch for creation and set default SELinux fcontexts"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="dev-libs/glib:2
+ >=sys-libs/libsepol-${PV}:=
+ >=sys-libs/libselinux-${PV}:="
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ SYSTEMDSYSTEMUNITDIR="$(systemd_get_systemunitdir)" \
+ SYSTEMDUSERUNITDIR=$(systemd_get_userunitdir) \
+ emake DESTDIR="${D}" install
+
+ rm -rf "${D}/etc/rc.d" || die
+
+ newinitd "${FILESDIR}/restorecond.init" restorecond
+}