summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-10-24 12:52:21 +0100
committerSam James <sam@gentoo.org>2021-10-31 02:50:23 +0000
commit3cdef6b4b412bbe52869d67e732456f6661241f9 (patch)
treeeaa59772a5bd1a06f072eeb1a40a676be356575b /sys-apps/restorecond/restorecond-3.3.ebuild
parentsys-apps/policycoreutils: Version updated to 3.3. (diff)
downloadgentoo-3cdef6b4b412bbe52869d67e732456f6661241f9.tar.gz
gentoo-3cdef6b4b412bbe52869d67e732456f6661241f9.tar.bz2
gentoo-3cdef6b4b412bbe52869d67e732456f6661241f9.zip
sys-apps/restorecond: Version updated to 3.3.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/restorecond/restorecond-3.3.ebuild')
-rw-r--r--sys-apps/restorecond/restorecond-3.3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/restorecond/restorecond-3.3.ebuild b/sys-apps/restorecond/restorecond-3.3.ebuild
new file mode 100644
index 000000000000..f3e66897e8c1
--- /dev/null
+++ b/sys-apps/restorecond/restorecond-3.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit systemd toolchain-funcs
+
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+fi
+
+DESCRIPTION="Daemon to watch for creation and set default SELinux fcontexts"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="dev-libs/glib:2
+ >=sys-libs/libsepol-${PV}:=
+ >=sys-libs/libselinux-${PV}:="
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ SYSTEMDSYSTEMUNITDIR="$(systemd_get_systemunitdir)" \
+ SYSTEMDUSERUNITDIR=$(systemd_get_userunitdir) \
+ emake DESTDIR="${D}" install
+
+ rm -rf "${D}/etc/rc.d" || die
+
+ newinitd "${FILESDIR}/restorecond.init" restorecond
+}