summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2020-09-01 20:28:38 +0000
committerJason Zaman <perfinion@gentoo.org>2020-09-14 20:40:31 -0700
commit3d0d4e7d6834fbb5a7e5a5a0ab819df74c5c61fd (patch)
tree26fc631b8b4eb329c286fe832b4fba5e1cb3e124 /sys-apps/restorecond
parentsys-apps/mcstrans: Version bump to 3.1. (diff)
downloadgentoo-3d0d4e7d6834fbb5a7e5a5a0ab819df74c5c61fd.tar.gz
gentoo-3d0d4e7d6834fbb5a7e5a5a0ab819df74c5c61fd.tar.bz2
gentoo-3d0d4e7d6834fbb5a7e5a5a0ab819df74c5c61fd.zip
sys-apps/restorecond: Version bump to 3.1.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps/restorecond')
-rw-r--r--sys-apps/restorecond/Manifest1
-rw-r--r--[-rwxr-xr-x]sys-apps/restorecond/files/restorecond.init0
-rw-r--r--sys-apps/restorecond/restorecond-3.1.ebuild56
-rw-r--r--sys-apps/restorecond/restorecond-9999.ebuild15
4 files changed, 65 insertions, 7 deletions
diff --git a/sys-apps/restorecond/Manifest b/sys-apps/restorecond/Manifest
index 887422d4fd5c..84f10cfb46bd 100644
--- a/sys-apps/restorecond/Manifest
+++ b/sys-apps/restorecond/Manifest
@@ -1,2 +1,3 @@
DIST restorecond-2.9.tar.gz 18893 BLAKE2B fcdae1a4ec489f3f581212cdd3c13c5561feac3ee758f354dca75c97938c62b9ed04aedbd4b3b5cde09a5887247389262718145620d0b9749e364d1614f57241 SHA512 6de9dd4c6b8e5d8275221aba5df27437998f635cfe83a5da75de479e260ceea884a36253eb873a8d71e1a77ed67544d8657fb75fe409af1f630052ce73ec5d8a
DIST restorecond-3.0.tar.gz 18797 BLAKE2B 354477ea9f57cc27c14a2648b99b32c45ac6d4e32caeb0fb108ed8f40a2e2e04101e2658d0107a1f2741717c242ad80b2e14db03488ab62b88eeb8b1a9ac0dd4 SHA512 f75088f72a17f1f7550ef67052202cea1fd9cf1bb1eec0355f4a0641ba25097b289f629df328ee79aec00f8361cbc6df10efc4a5af2f0b67f9922ceaf92aa956
+DIST restorecond-3.1.tar.gz 18939 BLAKE2B 3a3fcde057dad3ed05692d679ba27e0b24f191d92ed5114fa38cb5f846c4cc00d85bb09b5d4e560ed2b914444e0c2d1c407f6c03900610624d5626d05f2991bc SHA512 cdcf299f48b89a7c641ded9507b9b966bf648497394f8e988a9cb1ceb3224c86369706027f3416a4f9750836f7a8f4580a4b3df76673e03f897b383d7ed0e2c8
diff --git a/sys-apps/restorecond/files/restorecond.init b/sys-apps/restorecond/files/restorecond.init
index 709f1d1b9ece..709f1d1b9ece 100755..100644
--- a/sys-apps/restorecond/files/restorecond.init
+++ b/sys-apps/restorecond/files/restorecond.init
diff --git a/sys-apps/restorecond/restorecond-3.1.ebuild b/sys-apps/restorecond/restorecond-3.1.ebuild
new file mode 100644
index 000000000000..001d8cd6d3f8
--- /dev/null
+++ b/sys-apps/restorecond/restorecond-3.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit systemd toolchain-funcs
+
+MY_RELEASEDATE="20200710"
+
+MY_P="${P//_/-}"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Daemon to watch for creation and set default SELinux fcontexts"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${PV}:=
+ >=sys-libs/libselinux-${PV}:=
+ dev-libs/dbus-glib
+ dev-libs/libpcre:=
+ >=sys-libs/libcap-1.10-r10:="
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ SYSTEMDSYSTEMUNITDIR="$(systemd_get_systemunitdir)" \
+ SYSTEMDUSERUNITDIR=$(systemd_get_userunitdir) \
+ emake DESTDIR="${D}" install
+
+ rm -rf "${D}/etc/rc.d" || die
+
+ newinitd "${FILESDIR}/restorecond.init" restorecond
+}
diff --git a/sys-apps/restorecond/restorecond-9999.ebuild b/sys-apps/restorecond/restorecond-9999.ebuild
index efe40fb0d733..001d8cd6d3f8 100644
--- a/sys-apps/restorecond/restorecond-9999.ebuild
+++ b/sys-apps/restorecond/restorecond-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
-inherit toolchain-funcs
+inherit systemd toolchain-funcs
-MY_RELEASEDATE="20191204"
+MY_RELEASEDATE="20200710"
MY_P="${P//_/-}"
IUSE=""
@@ -32,8 +32,7 @@ DEPEND=">=sys-libs/libsepol-${PV}:=
dev-libs/libpcre:=
>=sys-libs/libcap-1.10-r10:="
-RDEPEND="${DEPEND}
- !<sys-apps/policycoreutils-2.7_pre"
+RDEPEND="${DEPEND}"
src_prepare() {
default
@@ -47,7 +46,9 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install
+ SYSTEMDSYSTEMUNITDIR="$(systemd_get_systemunitdir)" \
+ SYSTEMDUSERUNITDIR=$(systemd_get_userunitdir) \
+ emake DESTDIR="${D}" install
rm -rf "${D}/etc/rc.d" || die