summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuel Holland <samuel@sholland.org>2019-05-19 18:31:14 -0500
committerMichał Górny <mgorny@gentoo.org>2019-06-22 09:32:19 +0200
commit46f2423ad90ebb3200e50a212b816b9415aa5c9b (patch)
treea9687bcbfc99f8ed945bdd29ff90516d4ad196d3 /sys-apps/s6-portable-utils/s6-portable-utils-2.2.1.3.ebuild
parentsys-apps/s6-linux-utils: Version bump to 2.5.0.1 (diff)
downloadgentoo-46f2423ad90ebb3200e50a212b816b9415aa5c9b.tar.gz
gentoo-46f2423ad90ebb3200e50a212b816b9415aa5c9b.tar.bz2
gentoo-46f2423ad90ebb3200e50a212b816b9415aa5c9b.zip
sys-apps/s6-portable-utils: Version bump to 2.2.1.3
Signed-off-by: Samuel Holland <samuel@sholland.org> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-apps/s6-portable-utils/s6-portable-utils-2.2.1.3.ebuild')
-rw-r--r--sys-apps/s6-portable-utils/s6-portable-utils-2.2.1.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/s6-portable-utils/s6-portable-utils-2.2.1.3.ebuild b/sys-apps/s6-portable-utils/s6-portable-utils-2.2.1.3.ebuild
new file mode 100644
index 000000000000..f88473544beb
--- /dev/null
+++ b/sys-apps/s6-portable-utils/s6-portable-utils-2.2.1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Set of tiny portable unix utilities"
+HOMEPAGE="https://www.skarnet.org/software/s6-portable-utils/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static"
+
+RDEPEND="!static? ( >=dev-libs/skalibs-2.8.0.0:= )"
+DEPEND="${RDEPEND}
+ static? ( >=dev-libs/skalibs-2.8.0.0[static-libs] )
+"
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ # Avoid QA warning for LDFLAGS addition; avoid overriding -fstack-protector
+ sed -i -e 's/.*-Wl,--hash-style=both$/:/' -e '/-fno-stack-protector$/d' \
+ configure || die
+}
+
+src_configure() {
+ econf \
+ --bindir=/bin \
+ --dynlibdir=/usr/$(get_libdir) \
+ --libdir=/usr/$(get_libdir)/${PN} \
+ --with-dynlib=/usr/$(get_libdir) \
+ --with-lib=/usr/$(get_libdir)/skalibs \
+ --with-sysdeps=/usr/$(get_libdir)/skalibs \
+ $(use_enable static allstatic) \
+ $(use_enable static static-libc)
+}