summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-02-17 22:25:03 +0100
committerSam James <sam@gentoo.org>2023-02-21 08:01:00 +0000
commitfbb04ca99969920b94f6e9f0ec390c95da282c5b (patch)
tree8e873b5f411b28619d8bd28d632e4731836b7c69 /sys-apps/s6-rc/s6-rc-0.5.4.0.ebuild
parentsys-apps/s6: add 2.11.3.0 (diff)
downloadgentoo-fbb04ca99969920b94f6e9f0ec390c95da282c5b.tar.gz
gentoo-fbb04ca99969920b94f6e9f0ec390c95da282c5b.tar.bz2
gentoo-fbb04ca99969920b94f6e9f0ec390c95da282c5b.zip
sys-apps/s6-rc: add 0.5.4.0
The package newly installs library to /lib* rather than /usr/lib* because utilities are installed to /bin, therefore, they should link shared libraries from /lib*. The /lib/s6 destination is used helper utilities instead of /usr/libexec. See-also: https://github.com/gentoo/gentoo/pull/12120#discussion_r296437625 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/s6-rc/s6-rc-0.5.4.0.ebuild')
-rw-r--r--sys-apps/s6-rc/s6-rc-0.5.4.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-apps/s6-rc/s6-rc-0.5.4.0.ebuild b/sys-apps/s6-rc/s6-rc-0.5.4.0.ebuild
new file mode 100644
index 000000000000..855a1d6e3baf
--- /dev/null
+++ b/sys-apps/s6-rc/s6-rc-0.5.4.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Service manager for the s6 supervision suite"
+HOMEPAGE="https://www.skarnet.org/software/s6-rc/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ dev-lang/execline:=
+ dev-libs/skalibs:=
+ >=sys-apps/s6-2.11.3.0:=[execline]
+"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ # Avoid QA warning for LDFLAGS addition
+ sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+
+ local myconf=(
+ --bindir=/bin
+ --dynlibdir="/$(get_libdir)"
+ --libdir="/usr/$(get_libdir)/${PN}"
+ --libexecdir=/lib/s6
+ --with-dynlib="/$(get_libdir)"
+ --with-lib="/usr/$(get_libdir)/execline"
+ --with-lib="/usr/$(get_libdir)/s6"
+ --with-lib="/usr/$(get_libdir)/skalibs"
+ --with-sysdeps="/usr/$(get_libdir)/skalibs"
+ --enable-shared
+ --disable-allstatic
+ --disable-static
+ --disable-static-libc
+ )
+
+ econf "${myconf[@]}"
+}