summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-03-31 01:06:44 +0800
committerJason Zaman <perfinion@gentoo.org>2019-03-31 21:45:26 +0800
commit7627bb48d182ab602be7328aa9ea14d6e3372c8b (patch)
treed37c92fb975d475fb9480fbf75001aff198cd64a /sys-apps/semodule-utils/semodule-utils-2.9.ebuild
parentsys-apps/selinux-python: bump to 2.9 (diff)
downloadgentoo-7627bb48d182ab602be7328aa9ea14d6e3372c8b.tar.gz
gentoo-7627bb48d182ab602be7328aa9ea14d6e3372c8b.tar.bz2
gentoo-7627bb48d182ab602be7328aa9ea14d6e3372c8b.zip
sys-apps/semodule-utils: bump to 2.9
Signed-off-by: Jason Zaman <perfinion@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'sys-apps/semodule-utils/semodule-utils-2.9.ebuild')
-rw-r--r--sys-apps/semodule-utils/semodule-utils-2.9.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/semodule-utils/semodule-utils-2.9.ebuild b/sys-apps/semodule-utils/semodule-utils-2.9.ebuild
new file mode 100644
index 000000000000..bf80b21dfc42
--- /dev/null
+++ b/sys-apps/semodule-utils/semodule-utils-2.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+MY_RELEASEDATE="20190315"
+SEPOL_VER="${PV}"
+SELNX_VER="${PV}"
+
+MY_P="${P//_/-}"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="SELinux policy module utilities"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${SEPOL_VER}:="
+
+RDEPEND="${DEPEND}
+ !<sys-apps/policycoreutils-2.7_pre"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ install
+}