summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/systemd-readahead
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/systemd-readahead')
-rw-r--r--sys-apps/systemd-readahead/Manifest1
-rw-r--r--sys-apps/systemd-readahead/metadata.xml8
-rw-r--r--sys-apps/systemd-readahead/systemd-readahead-216.ebuild161
3 files changed, 170 insertions, 0 deletions
diff --git a/sys-apps/systemd-readahead/Manifest b/sys-apps/systemd-readahead/Manifest
new file mode 100644
index 000000000000..bb18cddab249
--- /dev/null
+++ b/sys-apps/systemd-readahead/Manifest
@@ -0,0 +1 @@
+DIST systemd-216.tar.xz 3612960 SHA256 945d3db7d840d6ffe98aa68394428e13317161ae79905397faab6671619728f3 SHA512 f4eee6664368168eafd61939f1355ac21c7eeecce6247de98ef36f40bb6a942d12c006ced4ee15f3d8f11699c194990222d5a5115b45f2aa81f2a1abafebbdd2 WHIRLPOOL 505e09b55209a4f9d8cec077970571b2e1298e8db02946a6c79df139dece9d1a08e46c86ef6c8053274abfd46c9a5ea09157f5bc9dc1f7461322c596e84ef494
diff --git a/sys-apps/systemd-readahead/metadata.xml b/sys-apps/systemd-readahead/metadata.xml
new file mode 100644
index 000000000000..8a0f59154c4c
--- /dev/null
+++ b/sys-apps/systemd-readahead/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pacho@gentoo.org</email>
+ <name>Pacho Ramos</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-apps/systemd-readahead/systemd-readahead-216.ebuild b/sys-apps/systemd-readahead/systemd-readahead-216.ebuild
new file mode 100644
index 000000000000..4a091da4966a
--- /dev/null
+++ b/sys-apps/systemd-readahead/systemd-readahead-216.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit systemd toolchain-funcs udev
+
+DESCRIPTION="Split of readahead systemd implementation"
+HOMEPAGE="http://dev.gentoo.org/~pacho/systemd-readahead.html"
+SRC_URI="http://www.freedesktop.org/software/systemd/systemd-${PV}.tar.xz"
+
+LICENSE="LGPL-2.1 MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+S=${WORKDIR}/systemd-${PV}
+
+RDEPEND=">=sys-apps/systemd-217:="
+DEPEND="${RDEPEND}
+ app-arch/xz-utils:0
+ dev-util/gperf
+ >=dev-util/intltool-0.50
+ >=sys-apps/coreutils-8.16
+ >=sys-devel/binutils-2.23.1
+ >=sys-kernel/linux-headers-3.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # systemd-notify no longer supports readahead playing
+ sed -i -e 's:ExecStart=@SYSTEMD_NOTIFY@ --readahead=done:ExecStart=/bin/touch /run/systemd/readahead/done:' \
+ units/systemd-readahead-done.service.in || die
+}
+
+src_configure() {
+ # Keep using the one where the rules were installed.
+ MY_UDEVDIR=$(get_udevdir)
+ # Fix systems broken by bug #509454.
+ [[ ${MY_UDEVDIR} ]] || MY_UDEVDIR=/lib/udev
+
+ local myeconfargs=(
+ # disable -flto since it is an optimization flag
+ # and makes distcc less effective
+ cc_cv_CFLAGS__flto=no
+
+ --enable-readahead
+
+ --disable-maintainer-mode
+ --localstatedir=/var
+ # make sure we get /bin:/sbin in $PATH
+ --enable-split-usr
+ # For testing.
+ --with-rootprefix="${ROOTPREFIX-/usr}"
+ --with-rootlibdir="${ROOTPREFIX-/usr}/$(get_libdir)"
+ # disable sysv compatibility
+ --with-sysvinit-path=
+ --with-sysvrcnd-path=
+ # Disable most of the stuff
+ --disable-efi
+ --disable-ima
+ --disable-acl
+ --disable-apparmor
+ --disable-audit
+ --disable-libcryptsetup
+ --disable-libcurl
+ --disable-gtk-doc
+ --disable-elfutils
+ --disable-gcrypt
+ --disable-gudev
+ --disable-microhttpd
+ --disable-gnutls
+ --disable-libidn
+ --disable-introspection
+ --disable-kdbus
+ --disable-kmod
+ --disable-lz4
+ --disable-xz
+ --disable-pam
+ --disable-polkit
+ --without-python
+ --disable-python-devel
+ --disable-qrencode
+ --disable-seccomp
+ --disable-selinux
+ --disable-tests
+ --disable-dbus
+
+ --disable-smack
+ --disable-blkid
+ --disable-multi-seat-x
+ --disable-myhostname
+
+ # Disable optional binaries
+ --disable-backlight
+ --disable-binfmt
+ --disable-bootchart
+ --disable-coredump
+ --disable-firstboot
+ --disable-hostnamed
+ --disable-localed
+ --disable-logind
+ --disable-machined
+ --disable-networkd
+ --disable-quotacheck
+ --disable-randomseed
+ --disable-resolved
+ --disable-rfkill
+ --disable-sysusers
+ --disable-timedated
+ --disable-timesyncd
+ --disable-tmpfiles
+ --disable-vconsole
+
+ # not supported (avoid automagic deps in the future)
+ --disable-chkconfig
+
+ # dbus paths
+ --with-dbuspolicydir="${EPREFIX}/etc/dbus-1/system.d"
+ --with-dbussessionservicedir="${EPREFIX}/usr/share/dbus-1/services"
+ --with-dbussystemservicedir="${EPREFIX}/usr/share/dbus-1/system-services"
+ --with-dbusinterfacedir="${EPREFIX}/usr/share/dbus-1/interfaces"
+ )
+
+ # Work around bug 463846.
+ tc-export CC
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ echo 'BUILT_SOURCES: $(BUILT_SOURCES)' > "${T}"/Makefile.extra
+ emake -f Makefile -f "${T}"/Makefile.extra BUILT_SOURCES
+
+ emake systemd-readahead
+ emake units/systemd-readahead-{drop,collect,replay,done}.service units/systemd-readahead-done.timer
+ emake man/{sd-readahead.3,sd_readahead.3,systemd-readahead-replay.service.8}
+}
+
+src_test() {
+ einfo "No specific tests for this"
+}
+
+src_install() {
+ # Install main app
+ exeinto /usr/lib/systemd/
+ doexe systemd-readahead
+
+ # Install unit files
+ systemd_dounit units/systemd-readahead-{drop,collect,replay,done}.service units/systemd-readahead-done.timer
+
+ # Install manpages and aliases
+ doman man/{sd-readahead.3,sd_readahead.3,systemd-readahead-replay.service.8}
+ newman man/systemd-readahead-replay.service.8 systemd-readahead-collect.service.8
+ newman man/systemd-readahead-replay.service.8 systemd-readahead-done.service.8
+ newman man/systemd-readahead-replay.service.8 systemd-readahead-done.timer.8
+ newman man/systemd-readahead-replay.service.8 systemd-readahead.8
+
+ # Install docs
+ dodoc TODO README
+}