summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-28 23:17:04 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-10-28 23:17:20 -0700
commite19af85ca42eaeeefb8e1083816e4d1ec1085c0d (patch)
tree65ee528a4105f2ee46c44b97fbf7cba51197eca7 /sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild
parentdev-libs/simdjson: Keyword 0.6.0-r1 arm, #751640 (diff)
downloadgentoo-e19af85ca42eaeeefb8e1083816e4d1ec1085c0d.tar.gz
gentoo-e19af85ca42eaeeefb8e1083816e4d1ec1085c0d.tar.bz2
gentoo-e19af85ca42eaeeefb8e1083816e4d1ec1085c0d.zip
sys-apps/systemd-tmpfiles: add missing BDEPEND section, rename files
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild')
-rw-r--r--sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild17
1 files changed, 15 insertions, 2 deletions
diff --git a/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild b/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild
index 5b99c6958bc7..141386b6e3e4 100644
--- a/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild
+++ b/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild
@@ -25,6 +25,18 @@ RDEPEND="${DEPEND}
!sys-apps/systemd
"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt:0
+ >=dev-util/meson-0.46
+ >=dev-util/intltool-0.50
+ >=sys-apps/coreutils-8.16
+ sys-devel/m4
+ virtual/pkgconfig
+"
+
S="${WORKDIR}/systemd-${PV}"
src_configure() {
@@ -151,8 +163,9 @@ src_install() {
newinitd "${FILESDIR}"/stmpfiles-dev.initd stmpfiles-dev
newinitd "${FILESDIR}"/stmpfiles-setup.initd stmpfiles-setup
- newconfd "${FILESDIR}"/stmpfiles-dev.confd stmpfiles-dev
- newconfd "${FILESDIR}"/stmpfiles-setup.confd stmpfiles-setup
+ # same content, but install as different file
+ newconfd "${FILESDIR}"/stmpfiles.confd stmpfiles-dev
+ newconfd "${FILESDIR}"/stmpfiles.confd stmpfiles-setup
}
# adapted from opentmpfiles ebuild